Modify

Opened 3 years ago

Closed 3 years ago

Last modified 22 months ago

#12909 closed defect (fixed)

negative position Exception

Reported by: aighes Owned by: team
Priority: normal Milestone: 16.06
Component: Core imagery Version:
Keywords: template_report jcs cache Cc: wiktorn

Description

What steps will reproduce the problem?

View with OSM-data and Bing Aerial was moved by mouse quite fast.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-02 02:46:59 +0200 (Thu, 02 Jun 2016)
Build-Date:2016-06-02 01:33:33
Revision:10316
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10316 en) Windows 10 64-Bit
Memory Usage: 3053 MB / 7282 MB (625 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- CADTools (1005)
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- apache-commons (32158)
- buildings_tools (32158)
- download_along (32158)
- ejml (32158)
- geotools (31895)
- jts (31906)
- log4j (32158)
- mbtiles (v2.0)
- measurement (32158)
- opendata (32158)
- pbf (32158)
- poly (32158)
- proj4j (32158)
- public_transport (32158)
- public_transport_layer (32158)
- reverter (32158)
- rex (1884)
- splinex (32158)
- terracer (32158)
- undelete (32158)
- utilsplugin2 (32158)
- waydownloader (32158)

Tagging presets:
- http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1

Map paint styles:
- E:\jOSM\boundary.mapcss
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1

Last errors/warnings:
- W: Unable to use English input method
- E: java.lang.IllegalArgumentException: Negative position

java.lang.IllegalArgumentException: Negative position
	at sun.nio.ch.FileChannelImpl.write(Unknown Source)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDisk.write(BlockDisk.java:216)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDiskCache.processUpdate(BlockDiskCache.java:399)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:815)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:673)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by Don-vip

Cc: wiktorn added
Component: CoreCore imagery
Keywords: jcs cache added

comment:2 Changed 3 years ago by wiktorn

Resolution: fixed
Status: newclosed

In 10323/josm:

Block/Indexed cache enhancements.

  • introduce a BooleanProperty that switches between Block and Indexed mode
  • introduce suffix for cache names based on type
  • clean stale files on cache initialization (clears indexed files when block mode is selected and vice versa, clears also no-prefix names)

Closes: #12909

comment:3 Changed 3 years ago by wiktorn

@Don-vip:

I recommend this patch for a bugfix release of 16.05

comment:4 Changed 3 years ago by Don-vip

ok :) with r10324:10327 we should have a pretty stable build for the last Java 7 release ever.

comment:5 Changed 3 years ago by Don-vip

Milestone: 16.06

comment:6 Changed 22 months ago by wiktorn

Ticket #15306 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.