Modify

Opened 4 years ago

Closed 4 years ago

#15286 closed defect (duplicate)

DataIntegrityProblemException: Primitive must be part of the dataset

Reported by: Nzara Owned by: Zverikk
Priority: normal Milestone:
Component: Plugin reltoolbox Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Copy some ways
  2. Paste them
  3. Undo

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Build-Date:2017-09-02 20:53:16
Revision:12712
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12712 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 630 MB / 910 MB (322 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djosm.cache=<josm.cache>]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33185)
+ buildings_tools (33004)
+ conflation (0.5.5)
+ jts (32699)
+ reltoolbox (33530)
+ terracer (33579)
+ turnrestrictions (33537)
+ utilsplugin2 (33579)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1

Map paint styles:
- https://github.com/igitov/forest-josm-style/archive/master.zip

Last errors/warnings:
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-106677 version=0 MVT nodes=[{Node id=-106679 version=0 MV lat=48.329651143447954,lon=10.056213314125348}, {Node id=-106680 version=0 MV lat=48.32968564357216,lon=10.056213814125348}, {Node id=-106681 version=0 MV lat=48.32968504356999,lon=10.05630891412535}, {Node id=-106682 version=0 MV lat=48.329650643446165,lon=10.056308514125348}, {Node id=-106683 version=0 MV lat=48.32965054344581,lon=10.056328314125347}, {Node id=-106684 version=0 MV lat=48.32933564231234,lon=10.056324314125346}, {Node id=-106685 version=0 MV lat=48.329336442315224,lon=10.056170014125348}, {Node id=-106686 version=0 MV lat=48.329413242591656,lon=10.056170914125348}, {Node id=-106687 version=0 MV lat=48.329413642593096,lon=10.056095114125347}, {Node id=-106688 version=0 MV lat=48.32953364302502,lon=10.056096614125348}, {Node id=-106689 version=0 MV lat=48.329651843450485,lon=10.056098214125347}, {Node id=-106690 version=0 MV lat=48.32965124344834,lon=10.056204414125347}, {Node id=-106679 version=0 MV lat=48.329651143447954,lon=10.056213314125348}]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-106677 version=0 MVT nodes=[{Node id=-106679 version=0 MV lat=48.329651143447954,lon=10.056213314125348}, {Node id=-106680 version=0 MV lat=48.32968564357216,lon=10.056213814125348}, {Node id=-106681 version=0 MV lat=48.32968504356999,lon=10.05630891412535}, {Node id=-106682 version=0 MV lat=48.329650643446165,lon=10.056308514125348}, {Node id=-106683 version=0 MV lat=48.32965054344581,lon=10.056328314125347}, {Node id=-106684 version=0 MV lat=48.32933564231234,lon=10.056324314125346}, {Node id=-106685 version=0 MV lat=48.329336442315224,lon=10.056170014125348}, {Node id=-106686 version=0 MV lat=48.329413242591656,lon=10.056170914125348}, {Node id=-106687 version=0 MV lat=48.329413642593096,lon=10.056095114125347}, {Node id=-106688 version=0 MV lat=48.32953364302502,lon=10.056096614125348}, {Node id=-106689 version=0 MV lat=48.329651843450485,lon=10.056098214125347}, {Node id=-106690 version=0 MV lat=48.32965124344834,lon=10.056204414125347}, {Node id=-106679 version=0 MV lat=48.329651143447954,lon=10.056213314125348}]}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:253)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:997)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1022)
	at relcontext.RelContextDialog.selectionChanged(RelContextDialog.java:382)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$OldListenerInfo.fire(SelectionEventManager.java:57)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvent(SelectionEventManager.java:203)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.lambda$selectionChanged$0(SelectionEventManager.java:198)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin reltoolbox
Owner: changed from team to Zverikk
Summary: uncexpected Error at pasteDataIntegrityProblemException: Primitive must be part of the dataset

comment:2 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15021.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Zverikk.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.