Modify

Opened 9 months ago

Closed 4 months ago

#15021 closed defect (duplicate)

DataIntegrityProblemException: Primitive must be part of the dataset

Reported by: anonymous Owned by: Zverikk
Priority: normal Milestone:
Component: Plugin reltoolbox Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-03 00:44:07 +0200 (Mon, 03 Jul 2017)
Build-Date:2017-07-02 23:26:36
Revision:12450
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12450 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1607 (14393)
Memory Usage: 405 MB / 910 MB (126 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djosm.home=C:/users/micha/JOSM/HalbTax, -Djosm.cache=<josm.cache>]
Dataset consistency test: No problems found

Plugins:
+ apache-commons (32994)
+ buildings_tools (33004)
+ pdfimport (33004)
+ pt_assistant (33429)
+ public_transport (33166)
+ reltoolbox (33311)
+ utilsplugin2 (33328)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}, methodWarningFrom=BugReportExceptionHandler#handleException]
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=4699268199 version=1 V lat=47.5308784,lon=8.5271054}, methodWarningFrom=BugReportExceptionHandler#handleException]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2425891111 version=1 V lat=47.5714009,lon=8.4706846}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:252)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:996)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1021)
	at relcontext.RelContextDialog.selectionChanged(RelContextDialog.java:380)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$OldListenerInfo.fire(SelectionEventManager.java:57)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvent(SelectionEventManager.java:203)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.lambda$selectionChanged$0(SelectionEventManager.java:198)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 9 months ago by Don-vip

Component: CorePlugin reltoolbox
Owner: changed from team to Zverikk
Summary: unexpected exceptionDataIntegrityProblemException: Primitive must be part of the dataset

comment:2 Changed 7 months ago by Don-vip

Ticket #15286 has been marked as a duplicate of this ticket.

comment:3 Changed 7 months ago by Zverikk

Could not reproduce this, even with a hint from #15286.

comment:4 Changed 4 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15008.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Zverikk.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.