Modify

Opened 4 years ago

Closed 4 years ago

#15284 closed enhancement (duplicate)

enhancement: add holidays (PH) to the opening hours instead of reporting an error

Reported by: Gorgonz <gorgonz@…> Owned by: boman
Priority: normal Milestone:
Component: Plugin openinghourseditor Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. create some opening hours manually and add "; PH Su off"
  2. activate Plugin opening hours
  3. select: edit (this) opening hours
  4. plugin reports a lexical error

What is the expected result?

well, you told, that it would not work, but i would argue for an error free reaction, so that users won't think, that this syntax is wrong. Best of course would be, to implement PH ;-)

What happens instead?

You get the lexical error

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-04 00:29:05 +0200 (Mon, 04 Sep 2017)
Build-Date:2017-09-03 22:31:22
Revision:12717
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12717 de) Linux openSUSE Leap 42.2
Memory Usage: 742 MB / 1765 MB (62 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
Java package: openjdk-8-jre:package openjdk-8-jre is not installed
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (33182)
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ gpxfilter (33004)
+ measurement (33088)
+ terracer (33579)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 82.  Encountered: "P" (80), after : ";"
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Ursache: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 82.  Encountered: "P" (80), after : ";"
- W: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 83.  Encountered: "P" (80), after : ""
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Ursache: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 83.  Encountered: "P" (80), after : ""

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8913.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain boman.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.