Modify

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#15283 closed defect (fixed)

Validator complains about Kapitän-Strasser-Straße

Reported by: GerdP Owned by: team
Priority: normal Milestone: 17.09
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Create highway=residential with name=Kapitän-Strasser-Straße somewhere in Germany
  2. Run validator

What is the expected result?

no warning

What happens instead?

Error "street name contains ss"

Please provide any additional information below. Attach a screenshot if possible.

The road exists a in two cities in Germany.
I think we should only check if wrong spelling of Srasse / Straße appears at the end of the name.

Build-Date:2017-09-10 07:33:07
Revision:12812
Is-Local-Build:true

Identification: JOSM/1.5 (12812 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 916 MB / 1753 MB (166 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:64140, -Dfile.encoding=UTF-8]
Program arguments: [--debug]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33185)
+ apache-commons (33517)
+ buildings_tools (33004)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ o5m (33566)
+ opendata (33553)
+ pbf (33568)
+ poly (33570)
+ reverter (33572)
+ utilsplugin2 (33579)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- W: Failed to locate resource '/README'.
- W: Failed to locate resource '/CONTRIBUTION'.
- W: Failed to locate resource '/LICENSE'.

Attachments (2)

15283.patch (802 bytes) - added by GerdP 20 months ago.
Strasser.osm (106.8 KB) - added by Klumbumbus 20 months ago.

Download all attachments as: .zip

Change History (11)

Changed 20 months ago by GerdP

Attachment: 15283.patch added

comment:1 Changed 20 months ago by GerdP

I just found out that we have names like "Gemeindestraße Amberg" in Austria. My patched test would not complain here.
Maybe someone knows the regex to allow Strasse when it is followed by Straße ?

comment:2 Changed 20 months ago by bastiK

You can use negative lookahead (?!X) or simply a second selector checking that addr:street does not contain Straße.

Changed 20 months ago by Klumbumbus

Attachment: Strasser.osm added

comment:3 Changed 20 months ago by Klumbumbus

There a more valid names containing strasser in germany, see just attached file.

comment:4 Changed 20 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 12815/josm:

fix #15283 - don't warn about street name contains ss for "strasser"

comment:5 Changed 20 months ago by Klumbumbus

Type: enhancementdefect

comment:6 Changed 20 months ago by Klumbumbus

Milestone: 17.09

comment:7 Changed 20 months ago by bastiK

assertMatch & assertNoMatch would be useful for this file.

comment:8 Changed 20 months ago by Klumbumbus

If I remember correctly, that doesn't work due to the territory selector.

comment:9 Changed 20 months ago by bastiK

Right, that makes sense.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.