Modify

Opened 4 years ago

Closed 4 years ago

#15260 closed defect (worksforme)

converting gpx layer to osm data layer results in empty file

Reported by: dieterdreist Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. load a gpx file in josm.
  2. right click on the layer and convert to osm data

What is the expected result?

some osm data made from the gpx file (the data was correctly displayed after loading the gpx file)

What happens instead?

empty osm data layer

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-07 01:05:36 +0200 (Thu, 07 Sep 2017)
Build-Date:2017-09-07 01:31:05
Revision:12767
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12767 en) Mac OS X 10.12.6
OS Build number: Mac OS X 10.12.6 (16G29)
Memory Usage: 692 MB / 1820 MB (334 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188875522 1920x1080, Display 458628992 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dsun.java2d.opengl=true]

Plugins:
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ SimplifyArea (33004)
+ alignways (33182)
+ apache-commons (33517)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ fieldpapers (v0.4.2)
+ geochat (33545)
+ geotools (33380)
+ imagery_offset_db (33547)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ opendata (33553)
+ photo_geotagging (33494)
+ print (33579)
+ reltoolbox (33530)
+ reverter (33572)
+ undelete (33480)
+ utilsplugin2 (33579)
+ wikipedia (33541)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Klumbumbus

Could you please attach the gpx file?

comment:2 Changed 4 years ago by dieterdreist

unfortunately I can't because it is copyrighted and I'm not the copyright holder. But I can confirm that of many files (all handdrawn in Garmin's old mapsource software, saved as gdb and converted with gpsbabel in gpx or exported directly as gpx from mapsource) only very few did convert correctly to OSM data (most resulted in empty files), but at least one did, so it's probably not an issue for "true" gpx tracks (device recordings with consecutive timestamps).

Before the conversion, all files displayed correctly as gpx layers and waypoint layers in JOSM.

Last edited 4 years ago by dieterdreist (previous) (diff)

comment:3 Changed 4 years ago by dieterdreist

Priority: majorminor

comment:4 in reply to:  2 Changed 4 years ago by Don-vip

Resolution: worksforme
Status: newclosed

Replying to dieterdreist:

it's probably not an issue for "true" gpx tracks (device recordings with consecutive timestamps).

Then not an issue at all. I tried with a gpx track and it works fine. Tell whoever created your invalid copyrighted file to fix it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.