Modify

Opened 3 years ago

Closed 3 years ago

#15256 closed defect (fixed)

limit roundabout validation test to waynodes all in downloaded area

Reported by: nyurik Owned by: nyurik
Priority: normal Milestone: 17.09
Component: Core validator Version:
Keywords: roundabout Cc:

Description (last modified by Klumbumbus)

osmwww:way/360593454 -- it seems like it should stay as highway=secondary. Should this autosuggest be disabled?

Attachments (1)

bug.osm (139.7 KB) - added by nyurik 3 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 3 years ago by Don-vip

Owner: changed from team to nyurik
Status: newneedinfo

What is your JOSM version?

comment:2 Changed 3 years ago by nyurik

v12712

comment:3 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:4 Changed 3 years ago by Klumbumbus

I can't reproduce this, but this is much likely a duplicate of #14092 (which I can't reproduce as well)

comment:5 Changed 3 years ago by Don-vip

Can't reproduce it neither. Please attach your status report and your .osm file.

comment:6 Changed 3 years ago by nyurik

Repo steps:

  • Ctrl+Shift+O - Download object 360593454
  • Ctrl+Alt+D - download parents
  • In relations window, right click relation 6988323 (should be the only one), and download incomplete members
  • Click on empty area to clear selection
  • Validate

Observe: Incorrect roundabout (highway: secondary instead of residential) (1)

Changed 3 years ago by nyurik

Attachment: bug.osm added

comment:7 Changed 3 years ago by Klumbumbus

The test should be limited to roundabouts whose waynodes are all :in-downloaded-area.

comment:8 Changed 3 years ago by Don-vip

Keywords: roundabout added
Milestone: 17.09
Summary: Incorrect? autosuggest for roundabouts -> residentiallimit roundabout validation test to waynodes all in downloaded area

comment:9 Changed 3 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 12864/josm:

fix #15256 - limit roundabout validation test to waynodes all in downloaded area

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nyurik.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.