Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#15196 closed defect (fixed)

NoClassDefFoundError: org/openstreetmap/josm/actions/search/SearchCompiler$ParseError

Reported by: naoliv Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin kendzi3d Version:
Keywords: regression Cc:

Description

I am reporting it against core, since I am unsure if it is being caused by some recent changes in JOSM.

While starting JOSM and loading kendzi3d:

2017-08-26 13:29:13.534 GRAVE: org.openstreetmap.josm.plugins.PluginException: Um erro ocorreu com o plugin kendzi3d. Causa: java.lang.reflect.InvocationTargetException. Causa: java.lang.NoClassDefFoundError: org/openstreetmap/josm/actions/search/SearchCompiler$ParseError. Causa: java.lang.ClassNotFoundException: org.openstreetmap.josm.actions.search.SearchCompiler$ParseError
org.openstreetmap.josm.plugins.PluginException: Um erro ocorreu com o plugin kendzi3d
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:330)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:781)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:864)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:903)
	at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:921)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:797)
Caused by: java.lang.reflect.InvocationTargetException
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:488)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:327)
	... 5 more
Caused by: java.lang.NoClassDefFoundError: org/openstreetmap/josm/actions/search/SearchCompiler$ParseError
	at java.base/java.lang.Class.getDeclaredConstructors0(Native Method)
	at java.base/java.lang.Class.privateGetDeclaredConstructors(Class.java:3110)
	at java.base/java.lang.Class.getDeclaredConstructors(Class.java:2314)
	at com.google.inject.spi.InjectionPoint.forConstructorOf(InjectionPoint.java:245)
	at com.google.inject.internal.ConstructorBindingImpl.create(ConstructorBindingImpl.java:100)
	at com.google.inject.internal.InjectorImpl.createUninitializedBinding(InjectorImpl.java:661)
	at com.google.inject.internal.UntargettedBindingProcessor$1.visit(UntargettedBindingProcessor.java:51)
	at com.google.inject.internal.UntargettedBindingProcessor$1.visit(UntargettedBindingProcessor.java:35)
	at com.google.inject.internal.UntargettedBindingImpl.acceptTargetVisitor(UntargettedBindingImpl.java:42)
	at com.google.inject.internal.UntargettedBindingProcessor.visit(UntargettedBindingProcessor.java:35)
	at com.google.inject.internal.UntargettedBindingProcessor.visit(UntargettedBindingProcessor.java:27)
	at com.google.inject.internal.BindingImpl.acceptVisitor(BindingImpl.java:93)
	at com.google.inject.internal.AbstractProcessor.process(AbstractProcessor.java:56)
	at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:187)
	at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
	at com.google.inject.Guice.createInjector(Guice.java:99)
	at com.google.inject.Guice.createInjector(Guice.java:73)
	at com.google.inject.Guice.createInjector(Guice.java:62)
	at kendzi.josm.kendzi3d.Kendzi3DPlugin.<init>(Kendzi3DPlugin.java:82)
	... 10 more
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.actions.search.SearchCompiler$ParseError
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:563)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:59)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
	... 29 more

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-08-26 15:29:22 +0200 (Sat, 26 Aug 2017)
Revision:12666
Build-Date:2017-08-26 14:04:15
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (12666 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 551 MB / 3072 MB (175 MB allocated, but free)
Java version: 9-Debian+0-9b181-4, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-9-jre:amd64-9~b181-4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [--add-modules=java.se.ee, -Dawt.useSystemAAFontSettings=on]

Plugins:
+ AddrInterpolation (33160)
+ CADTools (1007)
+ Create_grid_of_ways (32699)
+ FastDraw (33182)
+ FixAddresses (33182)
+ ImportImagePlugin (33372)
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ SimplifyArea (33004)
+ apache-commons (33517)
+ buildings_tools (33004)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geojson (52)
+ geotools (33380)
+ graphview (33004)
+ jogl (1.1.0)
+ jts (32699)
+ kendzi3d
+ kendzi3d-resources (0.0.1)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33436)
+ opendata (33519)
+ pdfimport (33004)
+ photo_geotagging (33494)
+ poly (33004)
+ reverter (33088)
+ tageditor (33021)
+ tagging-preset-tester (33004)
+ todo (30301)
+ turnlanes-tagging (254)
+ turnrestrictions (33537)
+ undelete (33480)
+ utilsplugin2 (33543)

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by michael2402

Cc: Don-vip added
Component: CorePlugin kendzi3d
Keywords: regression added
Owner: changed from team to kendzi

comment:2 Changed 2 years ago by Don-vip

Cc: Don-vip removed
Owner: changed from kendzi to Don-vip
Status: newassigned

comment:3 Changed 2 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

comment:5 Changed 2 years ago by Don-vip

Yes. This error will disappear once the PR is merged and a new version released.

comment:6 Changed 2 years ago by Klumbumbus

OK, nice.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.