Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#15168 closed defect (fixed)

Catch exception thrown with nmea malformatted data

Reported by: anonymous Owned by: team
Priority: normal Milestone: 17.08
Component: Core Version:
Keywords: template_report nmea Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-31 01:02:55 +0200 (Mon, 31 Jul 2017)
Build-Date:2017-07-31 01:53:17
Revision:12545
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12545 cs) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 120 MB / 247 MB (19 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: Date is malformed


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (52) of main
org.openstreetmap.josm.tools.JosmRuntimeException: Date is malformed
	at org.openstreetmap.josm.io.nmea.NmeaReader.readTime(NmeaReader.java:141)
	at org.openstreetmap.josm.io.nmea.NmeaReader.parseNMEASentence(NmeaReader.java:414)
	at org.openstreetmap.josm.io.nmea.NmeaReader.<init>(NmeaReader.java:197)
	at org.openstreetmap.josm.io.NMEAImporter.importData(NMEAImporter.java:47)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:92)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:355)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:308)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (1)

1.nmea (3.6 KB) - added by anonymous 2 years ago.

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by anonymous

Attachment: 1.nmea added

comment:1 Changed 2 years ago by bastiK

Resolution: invalid
Status: newclosed

Your NMEA file is not formatted correctly. Basically, it has decimal points replaced by commas, which makes it impossible to process.

comment:2 Changed 2 years ago by bastiK

In 12617/josm:

see #15168 - catch exceptions caused by malformatted data; dump limited number of errors to the command line

comment:3 Changed 2 years ago by Don-vip

Keywords: nmea added
Milestone: 17.08
Resolution: invalidfixed
Summary: nmea formatCatch exception thrown with nmea malformatted data

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.