Modify

Opened 2 years ago

Closed 2 years ago

#15150 closed defect (fixed)

Cant load preferences window.

Reported by: anonymous Owned by: team
Priority: normal Milestone: 17.08
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Click on Edit
  2. Click on Preferences

What is the expected result?

Should load the preferences window

What happens instead?

Error

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-31 01:02:55 +0200 (Mon, 31 Jul 2017)
Build-Date:2017-07-31 01:53:17
Revision:12545
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12545 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 416 MB / 910 MB (106 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Plugins:
+ FastDraw (32309)
+ Mapillary
+ contourmerge (1014)
+ editgpx (32485)
+ ext_tools (32309)
+ kendzi3d
+ kendzi3d-resources (0.0.1)
+ kendzi3d_Improved_by_Andrei
+ log4j (32309)
+ turnrestrictions (33088)

Tagging presets:
+ %UserProfile%\Downloads\2C Pokhara v21.xml

Last errors/warnings:
- W: No plugin to download, operation canceled
- W: Ext_Tools warning: can not load file <josm.pref>\plugins\ext_tools\tools.cfg
- W: Ext_Tools warning: can not load file <josm.pref>\plugins\ext_tools\repo.cfg
- W: Cannot start IPv4 remotecontrol server on port 8111: Address already in use: JVM_Bind
- W: Cannot start IPv6 remotecontrol server on port 8111: Address already in use: JVM_Bind
- W: Cannot start IPv4 remotecontrol https server on port 8112: Address already in use: JVM_Bind
- W: Cannot start IPv6 remotecontrol https server on port 8112: Address already in use: JVM_Bind
- W: No plugin to download, operation canceled
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/MapView$LayerChangeListener. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.MapView$LayerChangeListener
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/MapView$LayerChangeListener. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.MapView$LayerChangeListener


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/MapView$LayerChangeListener
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at java.security.SecureClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.access$100(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:59)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
	at java.lang.Class.privateGetMethodRecursive(Unknown Source)
	at java.lang.Class.getMethod0(Unknown Source)
	at java.lang.Class.getMethod(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginProxy.getPreferenceSetting(PluginProxy.java:78)
	at org.openstreetmap.josm.plugins.PluginPreferenceFactory.createPreferenceSetting(PluginPreferenceFactory.java:25)
	at org.openstreetmap.josm.gui.preferences.PreferenceTabbedPane.buildGui(PreferenceTabbedPane.java:447)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.build(PreferenceDialog.java:80)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.<init>(PreferenceDialog.java:52)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:106)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:101)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.MapView$LayerChangeListener
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:59)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 63 more

Attachments (1)

Capture.JPG (120.9 KB) - added by anonymous 2 years ago.

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by anonymous

Attachment: Capture.JPG added

comment:1 Changed 2 years ago by Don-vip

Several of your plugins seem corrupted, you should delete all of them and download/update them again. By the way you shouldn't use the two versions of kendzi3d I recommend to remove the "improved" version

comment:2 Changed 2 years ago by Don-vip

Milestone: 17.08

comment:3 Changed 2 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 12599/josm:

fix #15150 - catch NoClassDefFoundError in PluginProxy

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.