Modify

#15149 closed defect (fixed)

2 "Registered Toolbar Action" errors when creating a new preference file

Reported by: rickmastfan67 Owned by: team
Priority: trivial Milestone: 17.08
Component: Core Version: latest
Keywords: Cc:

Description (last modified by rickmastfan67)

Just happened to notice this when creating a new preference file to test a bug that I discovered.

Small errors, but they shouldn't be triggered either way.

Lines: 2017-08-14 03:11:59.236 & 2017-08-14 03:11:59.610

2017-08-14 03:11:55.320 INFO: Log level is at INFO (INFO, 800)
2017-08-14 03:11:55.330 INFO: Missing preference file 'C:\Users\(insert user profile name here)\AppData\Roaming\JOSM\preferences.xml'. Creating a default preference file.
2017-08-14 03:11:59.236 INFO: Registered toolbar action purge overwritten: org.openstreetmap.josm.actions.PurgeAction gets org.openstreetmap.josm.actions.PurgeAction
2017-08-14 03:11:59.276 INFO: GET https://josm.openstreetmap.de/wiki/StartupPage -> 200
2017-08-14 03:11:59.497 INFO: GET https://josm.openstreetmap.de/maps -> 200
2017-08-14 03:11:59.550 INFO: GET https://api.openstreetmap.org/api/capabilities -> 200 (434 B)
2017-08-14 03:11:59.550 INFO: OK
2017-08-14 03:11:59.610 INFO: Registered toolbar action joinareas overwritten: org.openstreetmap.josm.actions.JoinAreasAction gets org.openstreetmap.josm.actions.JoinAreasAction
[INFO] CompositeCacheManager - Instance is null, returning unconfigured instance

[WARN] ThreadPoolManager - No configuration settings found.  Using hardcoded default values for all pools.

Steps to reproduce:

  1. Delete the following folders (or rename them) in Windows so that JOSM will create a new profile: C:\Users\(insert user profile name here)\AppData\Roaming\JOSM & C:\Users\(insert user profile name here)\AppData\Local\JOSM
  2. Start JOSM with a command window in the background to catch the errors.

What happens:
The 2 mentioned "Registered Toolbar Action" errors will show up.

What should happen:
They shouldn't show up since you're making a fresh profile.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-08-13 19:54:54 +0200 (Sun, 13 Aug 2017)
Build-Date:2017-08-14 01:35:37
Revision:12598
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12598 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 440 MB / 1820 MB (162 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Another note, but the errors only show up on the first start. They don't show up on a second restart of JOSM after the new preference file has been created.

Attachments (0)

Change History (4)

comment:1 Changed 23 months ago by rickmastfan67

Description: modified (diff)

comment:2 Changed 23 months ago by Don-vip

Milestone: 17.08

comment:3 Changed 23 months ago by Don-vip

In 12601/josm:

see #15149 - less verbose logs when starting JOSM in debug

comment:4 Changed 23 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12602/josm:

fix #15149 - do not register actions in toolbar when loading internal osm databases (traffic/boundaries) for the first time

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.