Modify

Opened 3 years ago

Closed 3 years ago

#14918 closed defect (duplicate)

Error while shut down JOSM

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 1607 (14393)
Memory Usage: 989 MB / 989 MB (375 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1280x768
Maximum Screen Size: 1280x768
Dataset consistency test: No problems found

Plugins:
+ HouseNumberTaggingTool (33160)
+ Mapillary (v1.5.3)
+ RoadSigns (33204)
+ apache-commons (32994)
+ apache-http (32699)
+ auto_tools (1494971731)
+ buildings_tools (33004)
+ download_along (32946)
+ tagging-preset-tester (33004)
+ terracer (33088)
+ turnlanes (33294)
+ turnrestrictions (33088)
+ utilsplugin2 (33328)
+ wikipedia (33288)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ http://www.country-linedance.de/daten/Verkehrszeichen-vorlage.zip

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- W: Could not read from URL https://a.mapillary.com/v3/detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=8.4526277%2C49.5426228%2C8.4543282%2C49.5448401!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=8.4526277%2C49.5426228%2C8.4543282%2C49.5448401
- W: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/objects?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=8.5002999%2C49.524034%2C8.5005795%2C49.5243113
- W: Could not read from URL https://a.mapillary.com/v3/detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=8.5334372%2C49.4952948%2C8.5369348%2C49.4997335!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=8.5334372%2C49.4952948%2C8.5369348%2C49.4997335
- W: Failed to download icon regulatory--no-dogs--g1: javax.imageio.IIOException: Can't get input stream from URL!. Ursache: java.io.FileNotFoundException: https://www.mapillary.com/developer/api-documentation/images/traffic_sign/regulatory--no-dogs--g1.png
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Fehlerhafte Anfrage - <html>Der OSM-Server »api.openstreetmap.org« meldete eine fehlerhafte Anfrage.<br><br>Der angeforderte Bereich ist zu groß oder enthält zu viele Daten.<br>Versuchen Sie, einen kleineren Bereich herunterzuladen oder nutzen Sie einen Datenbankexport.</html>
- W: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/objects?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=8.6090836%2C49.4470857%2C8.6095342%2C49.4476411
- W: java.net.ConnectException: Connection timed out: connect
- W: Unable to convert property casing-color to type class java.awt.Color: found #66066 of type class java.lang.String!
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapObjectLayer [name=Mapillary-Objekte, associatedFile=null]


=== REPORTED CRASH DATA ===
LayerManager#fireLayerRemoving:
 - listener: org.openstreetmap.josm.gui.MapView[,0,0,391x637,alignmentX=0.0,alignmentY=0.0,border=,flags=0,maximumSize=,minimumSize=java.awt.Dimension[width=10,height=0],preferredSize=]
 - event: LayerRemoveEvent [removedLayer=MapObjectLayer [name=Mapillary-Objekte, associatedFile=null], lastLayer=false]
 - layer: MapObjectLayer [name=Mapillary-Objekte, associatedFile=null]

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalStateException: The layer has already been destroyed: MapObjectLayer [name=Mapillary-Objekte, associatedFile=null]
	at org.openstreetmap.josm.gui.layer.Layer.destroy(Layer.java:301)
	at org.openstreetmap.josm.gui.MapView.layerRemoving(MapView.java:398)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerRemoving(LayerManager.java:475)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveSingleLayer(LayerManager.java:277)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:266)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:265)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$removeLayer$1(LayerManager.java:247)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:247)
	at org.openstreetmap.josm.gui.layer.LayerManager.realResetState(LayerManager.java:511)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realResetState(MainLayerManager.java:376)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:502)
	at org.openstreetmap.josm.Main.shutdown(Main.java:865)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:130)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:841)
	at org.openstreetmap.josm.gui.MainFrame$ExitWindowAdapter.windowClosing(MainFrame.java:173)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.Window.processWindowEvent(Unknown Source)
	at javax.swing.JFrame.processWindowEvent(Unknown Source)
	at java.awt.Window.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by bastiK

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14848.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.