Modify

Opened 3 years ago

Closed 3 years ago

#14848 closed defect (fixed)

IllegalStateException: The layer has already been destroyed: MapObjectLayer

Reported by: anonymous Owned by: floscher
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 00:35:21 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-28 22:37:41
Revision:12271
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12271 it) Windows 7 64-Bit
OS Build number: Windows 7 Professional null (7601)
Memory Usage: 398 MB / 910 MB (114 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1680x1050, \Display1 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ Mapillary (v1.5.3)
+ apache-commons (32994)
+ apache-http (32699)
+ turnrestrictions (33088)

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapObjectLayer [name=Mapillary objects, associatedFile=null]


=== REPORTED CRASH DATA ===
LayerManager#fireLayerRemoving:
 - listener: org.openstreetmap.josm.gui.MapView[,0,0,1256x910,alignmentX=0.0,alignmentY=0.0,border=,flags=0,maximumSize=,minimumSize=java.awt.Dimension[width=10,height=0],preferredSize=]
 - event: LayerRemoveEvent [removedLayer=MapObjectLayer [name=Mapillary objects, associatedFile=null], lastLayer=false]
 - layer: MapObjectLayer [name=Mapillary objects, associatedFile=null]

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.IllegalStateException: The layer has already been destroyed: MapObjectLayer [name=Mapillary objects, associatedFile=null]
	at org.openstreetmap.josm.gui.layer.Layer.destroy(Layer.java:301)
	at org.openstreetmap.josm.gui.MapView.layerRemoving(MapView.java:398)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerRemoving(LayerManager.java:475)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveSingleLayer(LayerManager.java:277)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:266)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:265)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$removeLayer$1(LayerManager.java:247)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:247)
	at org.openstreetmap.josm.gui.layer.LayerManager.realResetState(LayerManager.java:511)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realResetState(MainLayerManager.java:376)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:502)
	at org.openstreetmap.josm.Main.shutdown(Main.java:865)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:130)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:841)
	at org.openstreetmap.josm.gui.MainFrame$ExitWindowAdapter.windowClosing(MainFrame.java:173)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.Window.processWindowEvent(Unknown Source)
	at javax.swing.JFrame.processWindowEvent(Unknown Source)
	at java.awt.Window.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Don-vip

Component: CorePlugin mapillary
Description: modified (diff)
Owner: changed from team to floscher
Summary: CiaoIllegalStateException: The layer has already been destroyed: MapObjectLayer

comment:2 Changed 3 years ago by bastiK

Ticket #14918 has been marked as a duplicate of this ticket.

comment:3 Changed 3 years ago by floscher

Resolution: fixed
Status: newclosed

This issue is probably fixed by commit b692108, which will be part of version v1.5.6 of the plugin.

That commit intended to fix https://josm.openstreetmap.de/ticket/14872 but it should also fix the issue described here.

Feel free to reopen this issue, if it occurs again.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain floscher.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.