Modify

Opened 2 years ago

Closed 2 years ago

#14894 closed defect (fixed)

ImportImage plugin does not display a georeferenced image in the correct position

Reported by: ar2988-os@… Owned by: ar2988-os@…
Priority: normal Milestone:
Component: Plugin importimage Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

The attached zip file contains 3 files:
14894.png is a blank image, 5000 × 5000 pixels.
14894.wld is the accompanying world file. It gives the image a scale of about 20cm per pixel, therefore a size of about 1km × 1km.
14894.osm contains a way showing the expected position of the edge of 14894.png when correctly projected.

  1. Put the .png and .wld files in the same folder.
  2. Open the osm file.
  3. Set the projection in JOSM to pseudo-Mercator, also called spherical Mercator (EPSG:3857).
  4. Use the ImportImage plugin to open the png file. When prompted, choose the current projection.
  5. Zoom in to a scale of about 10m with the lower right corner of the image in the view.
  6. Observe that the edge of the image is about 1m away from the expected position.

Please provide any additional information below. Attach a screenshot if possible.

Tested with r12039 because the ImportImage plugin crashes in r12275.
If you repeat the above, using the Piclayer plugin, the result is much closer to the expected result.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-02 23:28:33 +0200 (Tue, 02 May 2017)
Build-Date:2017-05-02 21:34:40
Revision:12039
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12039 en) Mac OS X 10.11.6
Memory Usage: 859 MB / 3641 MB (424 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 725375437 1920x1200
Maximum Screen Size: 1920x1200
VM arguments: [-Djosm.home=<josm.pref>]
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (33028)
+ ejml (32680)
+ geotools (33042)
+ jts (32699)
+ log4j (32699)

Attachments (1)

14894.zip (117.9 KB) - added by ar2988-os@… 2 years ago.

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by ar2988-os@…

Attachment: 14894.zip added

comment:1 Changed 2 years ago by Don-vip

Owner: changed from team to ar2988-os@…
Status: newneedinfo

Works for me now that #14889 is fixed. Can you please try with latest JOSM and following plugin versions:

+ ImportImagePlugin (33372)
+ geotools (33371)

comment:2 Changed 2 years ago by ar2988-os@…

Works for me now, thank you. (Tested with r12321.)

comment:3 Changed 2 years ago by ar2988-os@…

Resolution: fixed
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ar2988-os@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.