Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#14886 closed defect (fixed)

NPE at SelectAction.getLastCommandInDataset

Reported by: anonymous Owned by: michael2402
Priority: normal Milestone: 17.06
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 en) Windows 7 64-Bit
OS Build number: Windows 7 Ultimate null (7601)
Memory Usage: 612 MB / 843 MB (60 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (33160)
+ BuildingGeneralization (1010)
+ CADTools (1007)
+ Create_grid_of_ways (32699)
+ CustomizePublicTransportStop (0.4)
+ DirectDownload (33160)
+ DirectUpload (33182)
+ ElevationProfile (33215)
+ FastDraw (33182)
+ FixAddresses (33182)
+ HouseNumberTaggingTool (33160)
+ PicLayer (33148)
+ ShapeTools (1220)
+ SimplifyArea (33004)
+ alignways (33182)
+ apache-commons (32994)
+ buildings_tools (33004)
+ contourmerge (1030)
+ editgpx (33004)
+ ejml (32680)
+ ext_tools (33004)
+ geochat (33088)
+ geojson (52)
+ geotools (33338)
+ graphview (33004)
+ jna (32699)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33154)
+ photo_geotagging (33088)
+ photoadjust (33303)
+ pointInfo (33131)
+ public_transport (33166)
+ public_transport_layer (33350)
+ rasterfilters (33269)
+ reltoolbox (33311)
+ reverter (33088)
+ splinex (33160)
+ tag2link (33035)
+ tageditor (33021)
+ todo (30100)
+ utilsplugin2 (33328)
+ wikipedia (33288)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/caravan_site&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/SentieriItaliani&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountainbike&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Surveillance&zip=1
+ http://osmtools.de/josm/steps.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ http://somewhere.dk/email/josm/source.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Tracks&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Suburb&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ConscriptionStreetnumber&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NoFeature&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.mapcss

Validator rules:
+ http://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@4157386e
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@55e213f4
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@66e0089f
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@2d1c4664
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@5fb06bdf
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@246554f9
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@5a29d7e3
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@62b07e4d
- W: Conflicts detected - <html>There were 81 conflicts detected.</html>
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.actions.mapmode.SelectAction.getLastCommandInDataset(SelectAction.java:813)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.useLastMoveCommandIfPossible(SelectAction.java:793)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mousePressed(SelectAction.java:450)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by Don-vip

Summary: ProgramcrashNPE at SelectAction.getLastCommandInDataset

comment:2 Changed 2 years ago by Don-vip

Ticket #14888 has been marked as a duplicate of this ticket.

comment:3 Changed 2 years ago by Don-vip

Milestone: 17.06
Owner: changed from team to michael2402

regression of r12053

comment:4 Changed 2 years ago by michael2402

Resolution: fixed
Status: newclosed

In 12313/josm:

Fix #14886: We can't use old move command if there is no edit layer.

comment:5 Changed 2 years ago by Don-vip

Ticket #14954 has been marked as a duplicate of this ticket.

comment:6 Changed 2 years ago by Don-vip

Ticket #14975 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain michael2402.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.