Modify

Opened 15 years ago

Closed 11 years ago

#148 closed enhancement (fixed)

A method to remove downloaded data from RAM but without sending it for deletion

Reported by: rjmunro@… Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc: skyper

Description

When you load a large area into JOSM, it gets slow. It would be convenient to be able to remove a selection from JOSM without removing it from Open Street map itself. It should be possible to use either drag-selection or the search tool to choose what to be removed.

Attachments (0)

Change History (8)

comment:1 Changed 15 years ago by anonymous

Type: defectenhancement

comment:2 Changed 15 years ago by framm

Owner: changed from imi to framm

A "forget data" action has been added in a preview release not yet in the JOSM SVN:

http://www.remote.org/frederik/tmp/josm-with-forget.jar

I will commit the change after making some changes that have been suggested.

comment:3 Changed 15 years ago by imi

don't forget the undo-buffer of the edit-layer when clearing stuff out ;-)

maybe an option "clear undo-buffer" will help too, as there can be an vast amount of memory held captive.

comment:4 Changed 13 years ago by stoecker

Component: unspecifiedCore

comment:5 Changed 12 years ago by stoecker

Ticket #3979 has been marked as a duplicate of this ticket.

comment:6 Changed 12 years ago by skyper

Version: latest

I also would like this enhancement.

what happened the last 3 years ?
Would be nice to just open a part of the osm as new layer.

comment:7 Changed 12 years ago by skyper

Cc: skyper added

comment:8 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.