Modify

Opened 4 years ago

Closed 4 years ago

#14702 closed defect (duplicate)

Plugin loader prefers system installation instead of update

Reported by: cmuelle8 Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

java.lang.NoSuchFieldError: wayPredicate
        at org.openstreetmap.josm.plugins.measurement.MeasurementDialog.selectionChanged(MeasurementDialog.java:179)
        at org.openstreetmap.josm.data.osm.DataSet.fireSelectionChanged(DataSet.java:695)
        at org.openstreetmap.josm.actions.mapmode.SelectAction.confirmOrUndoMovement(SelectAction.java:852)
        at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseReleased(SelectAction.java:621)
        at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
        at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
        at java.awt.Component.processMouseEvent(Component.java:6533)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
        at java.awt.Component.processEvent(Component.java:6298)
        at java.awt.Container.processEvent(Container.java:2236)
        at java.awt.Component.dispatchEventImpl(Component.java:4889)
        at java.awt.Container.dispatchEventImpl(Container.java:2294)
        at java.awt.Component.dispatchEvent(Component.java:4711)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
        at java.awt.Container.dispatchEventImpl(Container.java:2280)
        at java.awt.Window.dispatchEventImpl(Window.java:2746)
        at java.awt.Component.dispatchEvent(Component.java:4711)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
        at java.awt.EventQueue.access$500(EventQueue.java:97)
        at java.awt.EventQueue$3.run(EventQueue.java:709)
        at java.awt.EventQueue$3.run(EventQueue.java:703)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
        at java.awt.EventQueue$4.run(EventQueue.java:731)
        at java.awt.EventQueue$4.run(EventQueue.java:729)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-04-25 03:18:09 +0200 (Tue, 25 Apr 2017)
Build-Date:2017-04-25 01:32:42
Revision:11999
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11999 de) Linux Ubuntu 16.10
Memory Usage: 558 MB / 1552 MB (353 MB allocated, but free)
Java version: 1.8.0_121-8u121-b13-0ubuntu1.16.10.2-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1280x1024
Maximum Screen Size: 1280x1024
Java package: openjdk-8-jre:amd64-8u121-b13-0ubuntu1.16.10.2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-9

Plugins:
+ PicLayer (33148)
+ RoadSigns (33204)
+ alignways (33182)
+ apache-commons (32994)
+ editgpx (32804)
+ imagery_offset_db (33004)
+ jogl (1.0.46)
+ kendzi3d (1.0.195)
+ kendzi3d-resources (0.0.1)
+ log4j (32699)
+ measurement (32804)
+ openvisible (32804)
+ pbf (33241)
+ photo_geotagging (33088)
+ photoadjust (33088)
+ poly (33004)
+ print (33260)
+ reverter (33088)
+ turnlanes (33088)
+ turnrestrictions (33088)
+ undelete (33263)
+ utilsplugin2 (33212)
+ wikipedia (33098)

Tagging presets:
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Hafen.xml
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT-1-preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'presets/empty.png'
- W:  Minefield (N34): Could not get presets icon presets/empty.png
- E: Fehler beim Laden des Bildes 'presets/empty.png'
- W:  Spoil Ground (N62.*): Could not get presets icon presets/empty.png
- E: Fehler beim Laden des Bildes 'presets/empty.png'
- W:  Extraction area (N63): Could not get presets icon presets/empty.png
- E: Fehler beim Laden des Bildes 'presets/empty.png'
- W:  Supplimentary Information: Could not get presets icon presets/empty.png
- E: Fehler beim Laden des Bildes 'presets/empty.png'
- W:  FIXMEs: Could not get presets icon presets/empty.png

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by cmuelle8

If the plugin is disabled, everything works as expected.

comment:2 Changed 4 years ago by Don-vip

Resolution: invalid
Status: newclosed

If the plugin is updated, everything works as expected. Current version is 33088.

comment:3 Changed 4 years ago by cmuelle8

Resolution: invalid
Status: closedreopened

This was a weird problem:

Everytime plugins were updated josm was fetching 33088,
but after a restart reverted to 32804.

Turns out an ubuntu packaged version was installed as well,
and there is also a package in yaketty called "josm-plugins".

System plugin path had version 32804, which is why it was
not useful to remove them from ~/.josm/plugins.

If there are plugins under /usr/share/josm/plugins
they are prefered over the ones in ~/.josm/plugins
_even if_ the plugin version in the latter is newer.

The system copy was removed by issuing

sudo apt-get remove josm josm-plugins

which removed the following files among others:

http://packages.ubuntu.com/yakkety/all/josm-plugins/filelist

While it does solve the problem (version 32048 is not prefered
over 33088 anymore), it should be handled differently imho.

-> If the user downloads a plugin to his home directory,
it should be prefered over the ones in the system path.
Afaik, this is common policy for pretty much all settings
in unix/linux.

Last edited 4 years ago by cmuelle8 (previous) (diff)

comment:4 Changed 4 years ago by stoecker

Component: Plugin measurementCore
Summary: [measurement plugin] plugin severly breaks drawing when moving nodes or creating waysPlugin loader prefers system installation instead of update

comment:5 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #7483.
Problem known for years, the package has been simply deleted recently.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.