Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#1469 closed enhancement (fixed)

[PATCH] Add method to apply virtual node to multiple ways

Reported by: dieterdreist Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: overlapping ways refine plus Cc:

Description

the refine nodes in selection mode (plus) is not working for overlapping ways. It should add nodes in all parts of the overlapping way, not just in the upper one.

Attachments (1)

Virtual For All.patch (7.8 KB) - added by xeen 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by anonymous

Resolution: wontfix
Status: newclosed

This is not intended. It will not connect ways. The new node is added in the selected way (previous selection use middle mouse or other methods works here too).

To add nodes to all ways use draw tool.

comment:2 Changed 10 years ago by dieterdreist

Resolution: wontfix
Status: closedreopened

sorry for the new attempt, but I dare to try again: I agree that it is not the desired functionality for ways which conincidentally overlap (without sharing adjacent nodes), but if two ways are overlapping at a given point and share the next node in both directions, this is in 98% of the cases the desired behaviour (often we are refining "rough" ways to put more precise information). This would be the case for all adjacent landuses, for buildings on the corner of squares, etc.

Otherwise the "red-plus"-function is not useful for refining overlapping ways as too complicated: for each single node to insert you would have to

  1. drag first plus
  2. drag the second plus below near the new node from 1.
  3. merge the nodes from 1 and 2
  4. move the merged node from 3 to the right position

but also a standard adding is mode-change-intensive:

  1. add a new node
  2. change to select-mode
  3. move the new node
  4. go back to 1 for the next mode.

comment:3 Changed 10 years ago by stoecker

Summary: overlapping ways and refine nodes in selection modeAdd method to apply virtual node to multiple ways

Possible we can add a modifier like "Ctrl" to reach the requested behaviour.

comment:4 Changed 10 years ago by stoecker

Status: reopenednew

Changed 10 years ago by xeen

Attachment: Virtual For All.patch added

comment:5 Changed 10 years ago by xeen

Summary: Add method to apply virtual node to multiple ways[PATCH] Add method to apply virtual node to multiple ways

Patch adds ALT as modifier to insert the virtual node into all ways that share this segment. This means it doesn't work for ways that only coincidentally have their virtual nodes on top of each other. E.g. the following example will only have the virtual node added to one of the ways:

   |
 --+--
   |

This feature is not exposed anywhere, status bar is already full anyway. Might want add this to the Advanced Features page in the OSM wiki though.

I found a call to updateStatusLine that I deem superfluous and also one to repaint(). For every move and select action this saves one redraw which should be a nice speed improvement if it works out as planned.

comment:6 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

Applied in r1441.

P.S. trn() is used to separate between 1/many. This also works for foreign languages :-)

comment:7 Changed 10 years ago by stoecker

Ticket #2734 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.