Modify

Opened 2 years ago

Closed 7 days ago

Last modified 7 days ago

#14598 closed defect (fixed)

Bing Imagery "Error: Attribution is not loaded yet"

Reported by: Interferometry Owned by: team
Priority: normal Milestone: 19.06
Component: JMapViewer Version:
Keywords: template_report bing attribution Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Zoom to location
  3. Select Imagery>'Bing aerial imagery'

What is the expected result?

Bing sat image background loads

What happens instead?

Background error grid appears; "Error: Attribution is not loaded yet"

Please provide any additional information below. Attach a screenshot if possible.

I'm new to JOSM, but the Bing imagery doesn't seem to be working out of the box for me. I've been trying to find a solution for this using the kb/tickets, but solutions to similar issues that have worked for others (previous ver of Java, deleting the Bing cache xml) haven't had any effect here. JOSM is requesting data from Bing but isn't able to properly use the API with the shipped default settings. I've checked on multiple machines and both via mobile and my usual domestic gateway. I don't appear to have any problematic firewall rules either, but created an exception anyway with no effect. I'm able to access tileserver.com via my browser normally.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-26 23:10:22 +0100 (Sun, 26 Feb 2017)
Build-Date:2017-02-26 22:34:39
Revision:11639
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11639 en_GB) Windows 10 64-Bit
Memory Usage: 185 MB / 247 MB (14 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\56\1ee8cfb8-24aca3f4, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=50349, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe]
Dataset consistency test: No problems found

Plugins:
+ imagery_offset_db (33004)
+ log4j (32699)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Failed to locate image 'http://nls.tileserver.com/nls70-nq8.png'
- E: Failed to locate image 'http://nls.tileserver.com/nls70-nq8.png'
- E: Failed to locate image 'http://nls.tileserver.com/nls70-nq8.png'

Attachments (0)

Change History (10)

comment:1 Changed 2 years ago by Don-vip

Component: CoreCore imagery
Keywords: bing attribution added

comment:2 Changed 2 years ago by bastiK

What is your result of checking on multiple machines?

I get the following command line output, can you post yours?

2017-04-01 17:59:42.061 WARNING: java.io.IOException: Attribution is not loaded yet
java.io.IOException: Attribution is not loaded yet
	at org.openstreetmap.gui.jmapviewer.tilesources.BingAerialTileSource.getTileUrl(BingAerialTileSource.java:83)
	at org.openstreetmap.gui.jmapviewer.Tile.getUrl(Tile.java:269)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.getUrl(TMSCachedTileLoaderJob.java:113)
        [...]

Bing: attribution data is not yet loaded.
Bing: attribution data is not yet loaded.
2017-04-01 17:59:42.219 INFO: GET https://dev.virtualearth.net/REST/v1/Imagery/Metadata/Aerial?include=ImageryProviders&output=xml&key=Arzdiw4nlOJzRwOz__qailc8NiR31Tt51dN2D7cm57NrnceZnCpgOkmJhNpGoppU -> 200
2017-04-01 17:59:42.235 INFO: Successfully loaded Bing attribution data.
2017-04-01 17:59:43.069 INFO: GET https://ecn.t1.tiles.virtualearth.net/tiles/a12020321000012.jpeg?g=5656 -> 200 (22.7 kB)

comment:3 Changed 2 years ago by anonymous

Resolution: fixed
Status: newclosed

comment:4 Changed 2 years ago by Don-vip

Resolution: fixed
Status: closedreopened

comment:5 Changed 7 weeks ago by Don-vip

Ticket #17766 has been marked as a duplicate of this ticket.

comment:6 Changed 7 days ago by Don-vip

Component: Core imageryJMapViewer
Milestone: 19.06
Resolution: fixed
Status: reopenedclosed

Fixed in [o35055].

comment:7 Changed 7 days ago by Don-vip

Ticket #5765 has been marked as a duplicate of this ticket.

comment:8 Changed 7 days ago by skyper

Waiting desperately for latest to see if the annoying reload of tiles at the beginning of a session finally comes to an end after 9 years.

comment:9 in reply to:  8 ; Changed 7 days ago by Don-vip

Replying to skyper:

Waiting desperately for latest

I've just built it manually, please test :)

comment:10 in reply to:  9 Changed 7 days ago by skyper

Replying to Don-vip:

Replying to skyper:

Waiting desperately for latest

I've just built it manually, please test :)

Woohh, awesome. thanks

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.