Modify

Opened 4 years ago

Closed 4 years ago

#14559 closed defect (duplicate)

IAE: Listener ... was not registered before or already removed.

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin imagewaypoint Version: tested
Keywords: template_report Cc:

Description (last modified by Don-vip)

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-03-23 00:01:04 +0100 (Thu, 23 Mar 2017)
Build-Date:2017-03-23 02:32:15
Revision:11772
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11772 it) Linux Debian GNU/Linux 9.0 (stretch)
Memory Usage: 269 MB / 1554 MB (44 MB allocated, but free)
Java version: 1.8.0_121-8u121-b13-4-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u121-b13-4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Dsun.java2d.opengl=false]

Plugins:
+ ColorPlugin (11)
+ ElevationProfile (33160)
+ ImageWayPoint (33086)
+ InfoMode (33004)
+ Mapillary (v1.4.2)
+ OpeningHoursEditor (33185)
+ PicLayer (33148)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ fieldpapers (v0.4.1)
+ geojson (52)
+ geotools (33042)
+ gpxfilter (33004)
+ importvec (33088)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33154)
+ opendata (33156)
+ pdfimport (33004)
+ photoadjust (33088)
+ turnlanes (33088)
+ undelete (32699)
+ utilsplugin2 (33182)
+ walkingpapers (32796)
+ wikipedia (33098)

Tagging presets:
+ /dati_ssd/<user.name>_old/bin/presets/trentino_strd_forst/Presets_TNTracks-preset.xml
+ /dati_ssd/<user.name>_old/bin/presets/CAI_sentieri/cai.xml

Last errors/warnings:
- E: Impossibile trovare l'immagine 'presets/track1.png'
- W:  Trentino: Could not get presets icon presets/track1.png
- E: Impossibile trovare l'immagine 'presets/track1.png'
- W:  Forestale Tipo A: Could not get presets icon presets/track1.png
- E: Impossibile trovare l'immagine 'presets/track1.png'
- W:  Forestale Tipo B: Could not get presets icon presets/track1.png
- W: Attenzione: è fallita l'analisi del file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' per le informazioni del modulo. Tralascio.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener Immagine del punto del percorso (instance of org.openstreetmap.josm.gui.dialogs.ToggleDialog) was not registered before or already removed.


=== REPORTED CRASH DATA ===
DialogsPanel#destroy:
 - dialog: Immagine del punto del percorso
 - dialog-class: class org.openstreetmap.josm.gui.dialogs.ToggleDialog

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (18) of main
java.lang.IllegalArgumentException: Listener Immagine del punto del percorso (instance of org.openstreetmap.josm.gui.dialogs.ToggleDialog) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:134)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:211)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:128)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:195)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:247)
	at org.openstreetmap.josm.gui.dialogs.ToggleDialog.destroy(ToggleDialog.java:460)
	at org.openstreetmap.josm.gui.dialogs.DialogsPanel.destroy(DialogsPanel.java:327)
	at org.openstreetmap.josm.gui.MapFrame.destroy(MapFrame.java:319)
	at org.openstreetmap.josm.gui.MainPanel.updateContent(MainPanel.java:58)
	at org.openstreetmap.josm.gui.MainPanel$1.afterLastLayerRemoved(MainPanel.java:160)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:270)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:229)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$removeLayer$1(LayerManager.java:215)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:215)
	at org.openstreetmap.josm.gui.dialogs.layer.DeleteLayerAction.actionPerformed(DeleteLayerAction.java:52)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at org.GNOME.Accessibility.AtkWrapper$5.dispatchEvent(AtkWrapper.java:700)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin imagewaypoint
Description: modified (diff)
Summary: CrashIAE: Listener ... was not registered before or already removed.

comment:2 Changed 4 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14062.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.