Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#14558 closed defect (fixed)

wmts layer don't work since last JOSM update

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 17.03
Component: Core imagery Version:
Keywords: template_report wmts Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-26 23:10:22 +0100 (Sun, 26 Feb 2017)
Build-Date:2017-02-26 22:34:39
Revision:11639
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11639 en_GB) Windows 10 64-Bit
Memory Usage: 1194 MB / 1778 MB (662 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ DirectDownload (33160)
+ DirectUpload (33182)
+ HouseNumberTaggingTool (33160)
+ ImportImagePlugin (33028)
+ Mapillary (v1.4.2)
+ OpenStreetCam (53)
+ OpeningHoursEditor (33185)
+ PicLayer (33148)
+ RoadSigns (33179)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ ext_tools (33004)
+ geotools (33042)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ ods-bag (0.6.10)
+ opendata (33156)
+ opendataservices (0.6.10)
+ pbf (33165)
+ photo_geotagging (33088)
+ poly (33004)
+ reverter (33088)
+ tag2link (33035)
+ tagging-preset-tester (33004)
+ terracer (33088)
+ turnlanes (33088)
+ turnrestrictions (33088)
+ undelete (32699)
+ utilsplugin2 (33182)
+ wikipedia (33098)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
+ Y:\== Routes\JOSM\== BAG\BAG Import Plugin Open Street Map JOSM\BAG\BAG\bag-plugin-0.6.8\Bag-plugin-0.6.8\Ods-bag-style-0.6.8 - kopie.mapcss
- Y:\== Routes\JOSM\== BAG\BAG Import Plugin Open Street Map JOSM\BAG\BAG\bag-plugin-0.6.8\Bag-plugin-0.6.8\Ods-bag-style-0.6.8.mapcss
- Y:\== Routes\JOSM\== BAG\BAG Import Plugin Open Street Map JOSM\BAG\BAG\Style Sheet Peewee\Style Sheet Fin (Ilpo) over NL borden\nlsigns\nlsigns-all.mapcss
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Potlach2_access&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedCycleNodeNetworks&zip=1

Last errors/warnings:
- W: Failed to scan file 'site-developer.skobbler.com-_public_openstreetview_OpenStreetView_jar.txt' for plugin information. Skipping.
- E: org.openstreetmap.josm.plugins.PluginListParseException: java.io.IOException: Illegal entry in plugin list.. Cause: java.io.IOException: Illegal entry in plugin list.
- W: Failed to load https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss, use cached file and retry next time: java.io.IOException: The requested URL https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss was not found
- W: Failed to load https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss, use cached file and retry next time: java.io.IOException: The requested URL https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss was not found
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
MapView#paintLayer:
 - layer: WMTSLayer [info=ImageryInfo{name='21. BAG WMTS', countryCode='', url='http://geodata.nationaalgeoregister.nl/tiles/service/wmts/bag?request=GetCapabilities', imageryType=WMTS}]

Warning issued by: MapView#paintLayer

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException
	at java.util.regex.Matcher.appendReplacement(Unknown Source)
	at java.util.regex.Matcher.replaceAll(Unknown Source)
	at java.lang.String.replaceAll(Unknown Source)
	at org.openstreetmap.josm.data.imagery.WMTSTileSource.getTileUrl(WMTSTileSource.java:653)
	at org.openstreetmap.josm.data.imagery.WMTSTileSource.getTileId(WMTSTileSource.java:788)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.getCacheKey(TMSCachedTileLoaderJob.java:94)
	at org.openstreetmap.josm.data.imagery.WMSCachedTileLoaderJob.getCacheKey(WMSCachedTileLoaderJob.java:40)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.<init>(TMSCachedTileLoaderJob.java:72)
	at org.openstreetmap.josm.data.imagery.WMSCachedTileLoaderJob.<init>(WMSCachedTileLoaderJob.java:34)
	at org.openstreetmap.josm.data.imagery.WMSCachedTileLoader.createTileLoaderJob(WMSCachedTileLoader.java:45)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.loadTile(AbstractTileSourceLayer.java:992)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.access$500(AbstractTileSourceLayer.java:117)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSet.loadAllTiles(AbstractTileSourceLayer.java:1355)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSet.access$1200(AbstractTileSourceLayer.java:1270)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.drawInViewArea(AbstractTileSourceLayer.java:1556)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.access$2900(AbstractTileSourceLayer.java:117)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.doPaint(AbstractTileSourceLayer.java:1945)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.paint(AbstractTileSourceLayer.java:1940)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:441)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:501)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JSplitPane.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (9)

comment:1 Changed 2 years ago by Don-vip

Component: CoreCore imagery
Keywords: wmts added

comment:2 Changed 2 years ago by wiktorn

Owner: changed from team to wiktorn
Status: newassigned

comment:3 Changed 2 years ago by wiktorn

In 11773/josm:

Fix NPE when there is no supported format for WMTS Tile Source

  • generate warning when no supported format was found in GetCapabilities document
  • skip layers with no supported formats

See: #14558

comment:4 Changed 2 years ago by wiktorn

Owner: changed from wiktorn to anonymous
Status: assignedneedinfo

Please try with the version [11773]. I couldn't reproduce the problem on my computer. It would help, if you'd provide also the name of the layer for which you've noticed the problem.

comment:5 in reply to:  4 Changed 2 years ago by anonymous

Replying to wiktorn:

Please try with the version [11773]. I couldn't reproduce the problem on my computer. It would help, if you'd provide also the name of the layer for which you've noticed the problem.

it is:
wmts:http://geodata.nationaalgeoregister.nl/tiles/service/wmts/bgtachtergrond?SERVICE=WMTS&request=GetCapabilities
(bgtstandaard wmts layer)

comment:6 Changed 2 years ago by bastiK

Resolution: fixed
Status: needinfoclosed

In 11824/josm:

fixed #14558 - add image/png8 as supported format

comment:7 Changed 2 years ago by bastiK

Milestone: 17.03

comment:8 Changed 2 years ago by anonymous

Version 11826 installed.
The error is solved but, wmts "bgtstandaard" layer is not displaying.
Error: Problem loading tile

https://www.dropbox.com/s/t3zwo802uvjvzf2/2017-04-02_23-06-35.jpg

2017-04-02 22:40:54.183 INFO: GET https://geodata.nationaalgeoregister.nl/tiles/service/wmts?SERVICE=WMTS&REQUEST=GetTile&VERSION=1.0.0&LAYER=bgtstandaard&STYLE=&FORMAT=image/png8&tileMatrixSet=EPSG:28992:16&tileMatrix=EPSG:28992:16:7&tileRow=77&tileCol=52 -> !!!
2017-04-02 22:40:54.187 WARNING: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Cause: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Cause: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

at sun.security.ssl.Alerts.getSSLException(Unknown Source)
at sun.security.ssl.SSLSocketImpl.fatal(Unknown Source)
at sun.security.ssl.Handshaker.fatalSE(Unknown Source)
at sun.security.ssl.Handshaker.fatalSE(Unknown Source)
at sun.security.ssl.ClientHandshaker.serverCertificate(Unknown Source)
at sun.security.ssl.ClientHandshaker.processMessage(Unknown Source)
at sun.security.ssl.Handshaker.processLoop(Unknown Source)
at sun.security.ssl.Handshaker.process_record(Unknown Source)
at sun.security.ssl.SSLSocketImpl.readRecord(Unknown Source)
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)
at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at sun.net.www.protocol.https.HttpsClient.afterConnect(Unknown Source)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(Unknown Source)
at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:125)
at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:75)
at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.loadObject(JCSCachedTileLoaderJob.java:330)
at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:240)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

comment:9 Changed 2 years ago by stoecker

Very likely the certificate issuer is not supported by Java and needs to be imported manually.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.