Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#14391 closed defect (fixed)

NPE in FileWatcher.start (Linux)

Reported by: darwish.d.d@… Owned by: team
Priority: normal Milestone: 17.02
Component: Core Version:
Keywords: template_report inotify linux kernel Cc:

Description

What steps will reproduce the problem?

  1. Just launch JOSM

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-02 01:22:52 +0100 (Thu, 02 Feb 2017)
Build-Date:2017-02-02 02:33:28
Revision:11526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11526 en) Linux Ubuntu 14.04.5 LTS
Memory Usage: 302 MB / 3500 MB (195 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-3~14.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080, :0.1 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u111-b14-3~14.04.1
Java ATK Wrapper package: libatk-wrapper-java:all-0.30.4-4
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
+ DirectUpload
+ editgpx
+ imagery_offset_db

Last errors/warnings:
- E: java.io.IOException: User limit of inotify instances reached or too many open files
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.NullPointerException
	at org.openstreetmap.josm.io.FileWatcher.start(FileWatcher.java:54)
	at org.openstreetmap.josm.Main.initialize(Main.java:510)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:335)

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by Don-vip

Keywords: inotify linux kernel added
Milestone: 17.02

comment:2 Changed 2 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 11589/josm:

fix #14391 - robustness to Linux systems preventing file watcher to start because of incorrect kernel inotify watch configuration

comment:3 Changed 2 years ago by Don-vip

Summary: JOSM crushed on startNPE in FileWatcher.start (Linux)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.