Modify

Opened 3 years ago

Closed 3 years ago

Last modified 23 months ago

#14342 closed defect (duplicate)

RangeViolatedError: the new range must be within a single subrange (2)

Reported by: v.v.chebotar@… Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-02 01:22:52 +0100 (Thu, 02 Feb 2017)
Build-Date:2017-02-02 02:33:28
Revision:11526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11526 ru) Windows 7 32-Bit
Memory Usage: 267 MB / 989 MB (48 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ turnrestrictions (33088)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: java.lang.AssertionError. Причина: java.lang.AssertionError: Range violated: the new range must be within a single subrange (2) (object: линия 407543694, current style: org.openstreetmap.josm.gui.mappaint.StyleCache@1ef47882, scale: 73.18445526284921, new stylelist: [LineElemStyle{z_idx=[3.0/0.0/0.0] width=2.0 realWidth=0.0 color=#0000ff dashed=null dashedColor=null linejoin=round linecap=round}, LineElemStyle{z_idx=[3.0/2.0/0.0] width=1.0 realWidth=0.0 color=#ff6600 dashed=[9.0, 9.0] dashedColor=null linejoin=round linecap=none}], new range: |s29.858214173896975-955.4628535647032). Причина: org.openstreetmap.josm.gui.mappaint.DividedScale$RangeViolatedError: the new range must be within a single subrange (2)
- E: Handled by bug report queue: java.lang.AssertionError. Причина: java.lang.AssertionError: Range violated: the new range must be within a single subrange (2) (object: линия 407543694, current style: org.openstreetmap.josm.gui.mappaint.StyleCache@1ef47882, scale: 73.18445526284921, new stylelist: [LineElemStyle{z_idx=[3.0/0.0/0.0] width=2.0 realWidth=0.0 color=#0000ff dashed=null dashedColor=null linejoin=round linecap=round}, LineElemStyle{z_idx=[3.0/2.0/0.0] width=1.0 realWidth=0.0 color=#ff6600 dashed=[9.0, 9.0] dashedColor=null linejoin=round linecap=none}], new range: |s29.858214173896975-955.4628535647032). Причина: org.openstreetmap.josm.gui.mappaint.DividedScale$RangeViolatedError: the new range must be within a single subrange (2)


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.AssertionError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
	at java.lang.reflect.Constructor.newInstance(Unknown Source)
	at java.util.concurrent.ForkJoinTask.getThrowableException(Unknown Source)
	at java.util.concurrent.ForkJoinTask.reportException(Unknown Source)
	at java.util.concurrent.ForkJoinTask.join(Unknown Source)
	at java.util.concurrent.ForkJoinPool.invoke(Unknown Source)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:1954)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:433)
	at org.openstreetmap.josm.gui.layer.AbstractMapViewPaintable$CompatibilityModeLayerPainter.paint(AbstractMapViewPaintable.java:27)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:441)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:522)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.AssertionError: Range violated: the new range must be within a single subrange (2) (object: линия 407543694, current style: org.openstreetmap.josm.gui.mappaint.StyleCache@1ef47882, scale: 73.18445526284921, new stylelist: [LineElemStyle{z_idx=[3.0/0.0/0.0] width=2.0 realWidth=0.0 color=#0000ff dashed=null dashedColor=null linejoin=round linecap=round}, LineElemStyle{z_idx=[3.0/2.0/0.0] width=1.0 realWidth=0.0 color=#ff6600 dashed=[9.0, 9.0] dashedColor=null linejoin=round linecap=none}], new range: |s29.858214173896975-955.4628535647032)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getStyleCacheWithRange(ElemStyles.java:169)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.get(ElemStyles.java:102)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.add(StyledMapRenderer.java:1912)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.visit(StyledMapRenderer.java:1880)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:211)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.acceptDrawable(StyledMapRenderer.java:1866)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.computeDirectly(StyledMapRenderer.java:1853)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.compute(StyledMapRenderer.java:1834)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.compute(StyledMapRenderer.java:1797)
	at java.util.concurrent.RecursiveTask.exec(Unknown Source)
	at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
	at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(Unknown Source)
	at java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
	at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)
Caused by: org.openstreetmap.josm.gui.mappaint.DividedScale$RangeViolatedError: the new range must be within a single subrange (2)
	at org.openstreetmap.josm.gui.mappaint.DividedScale.putImpl(DividedScale.java:147)
	at org.openstreetmap.josm.gui.mappaint.DividedScale.put(DividedScale.java:102)
	at org.openstreetmap.josm.gui.mappaint.StyleCache.put(StyleCache.java:50)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getStyleCacheWithRange(ElemStyles.java:166)
	... 13 more

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Don-vip

Component: CoreCore mappaint
Description: modified (diff)
Summary: bag reportDividedScale$RangeViolatedError: the new range must be within a single subrange

comment:2 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13170.

comment:3 Changed 23 months ago by Don-vip

Summary: DividedScale$RangeViolatedError: the new range must be within a single subrangeRangeViolatedError: the new range must be within a single subrange (2)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.