Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14295 closed defect (duplicate)

Josm freezed after changing the Map paint styles, and raised an exception at closing

Reported by: FrViPofm Owned by: team
Priority: normal Milestone:
Component: Plugin conflation Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. changed the style list
  2. closed the setting window (closed after a veeeryyyy long time)
  3. closed JOSM (raised this exception)

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-01-25 02:17:36 +0100 (Wed, 25 Jan 2017)
Build-Date:2017-01-25 02:33:55
Revision:11490
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11490 fr) Linux Ubuntu 16.04.1 LTS
Memory Usage: 910 MB / 910 MB (115 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-2ubuntu0.16.04.2-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u111-b14-2ubuntu0.16.04.2
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
+ ImageWayPoint (33086)
+ ImportImagePlugin (33028)
+ Mapillary (v1.3.2)
+ OpenStreetCam (42)
+ OpeningHoursEditor (33004)
+ PicLayer (33088)
+ apache-commons (32994)
+ apache-http (32699)
+ cadastre-fr (33088)
+ conflation (0.3.0)
+ ejml (32680)
+ geotools (33042)
+ jna (32699)
+ jts (32699)
+ log4j (32699)
+ merge-overlap (33004)
+ native_password_manager (33088)
+ public_transport (33088)
+ public_transport_layer (33088)
+ reverter (33088)
+ tag2link (33035)
+ turnrestrictions (33088)
+ undelete (32699)
+ utilsplugin2 (33124)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Industrial&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/FR.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1

Last errors/warnings:
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener Conflation (instance of org.openstreetmap.josm.plugins.conflation.ConflationToggleDialog) was not registered before or already removed.


=== REPORTED CRASH DATA ===
DialogsPanel#destroy:
 - dialog: Conflation
 - dialog-class: class org.openstreetmap.josm.plugins.conflation.ConflationToggleDialog

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Listener Conflation (instance of org.openstreetmap.josm.plugins.conflation.ConflationToggleDialog) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:134)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:211)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:128)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:195)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:246)
	at org.openstreetmap.josm.gui.dialogs.ToggleDialog.destroy(ToggleDialog.java:460)
	at org.openstreetmap.josm.gui.dialogs.DialogsPanel.destroy(DialogsPanel.java:326)
	at org.openstreetmap.josm.gui.MapFrame.destroy(MapFrame.java:320)
	at org.openstreetmap.josm.gui.MainPanel.updateContent(MainPanel.java:58)
	at org.openstreetmap.josm.gui.MainPanel$1.afterLastLayerRemoved(MainPanel.java:160)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:270)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:228)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$removeLayer$1(LayerManager.java:214)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:214)
	at org.openstreetmap.josm.gui.layer.LayerManager.realResetState(LayerManager.java:455)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realResetState(MainLayerManager.java:376)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:449)
	at org.openstreetmap.josm.Main.shutdown(Main.java:879)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:119)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:858)
	at org.openstreetmap.josm.gui.MainFrame$ExitWindowAdapter.windowClosing(MainFrame.java:162)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.Window.processWindowEvent(Window.java:2054)
	at javax.swing.JFrame.processWindowEvent(JFrame.java:305)
	at java.awt.Window.processEvent(Window.java:2013)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by skyper

Component: CorePlugin conflation
Resolution: duplicate
Status: newclosed

Closed as duplicate of #14136.

comment:2 Changed 6 years ago by Klumbumbus

  • E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
  • E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]

fixed in https://josm.openstreetmap.de/wiki/Presets/Heritage?action=diff&version=56

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.