Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14211 closed defect (fixed)

InaccessibleObjectException with JDK 9 b148+

Reported by: anonymous Owned by: team
Priority: normal Milestone: 17.01
Component: Core Version:
Keywords: java9 Cc:

Description

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-01-02 00:53:29 +0100 (Mon, 02 Jan 2017)
Revision:11427
Build-Date:2017-01-02 02:33:21
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (11427 es) Linux Ubuntu 14.04.5 LTS
Memory Usage: 38 MB / 502 MB (15 MB allocated, but free)
Java version: 9-ea+149, Oracle Corporation, Java HotSpot(TM) Server VM
Screen: :0.0 1280x800
Maximum Screen Size: 1280x800
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Last errors/warnings:
- E: Handled by bug report queue: java.lang.reflect.InaccessibleObjectException: Unable to make field private static java.util.ResourceBundle java.awt.Toolkit.resources accessible: module java.desktop does not "opens java.awt" to unnamed module @d87d80


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.reflect.InaccessibleObjectException: Unable to make field private static java.util.ResourceBundle java.awt.Toolkit.resources accessible: module java.desktop does not "opens java.awt" to unnamed module @d87d80
	at java.base/jdk.internal.reflect.Reflection.throwInaccessibleObjectException(Reflection.java:427)
	at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:201)
	at java.base/java.lang.reflect.Field.checkCanSetAccessible(Field.java:171)
	at java.base/java.lang.reflect.Field.setAccessible(Field.java:165)
	at org.openstreetmap.josm.tools.Utils.lambda$setObjectsAccessible$0(Utils.java:1463)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at org.openstreetmap.josm.tools.Utils.setObjectsAccessible(Utils.java:1461)
	at org.openstreetmap.josm.data.Preferences.updateSystemProperties(Preferences.java:1429)
	at org.openstreetmap.josm.data.Preferences.load(Preferences.java:662)
	at org.openstreetmap.josm.data.Preferences.init(Preferences.java:763)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:255)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Don-vip

Keywords: java9 added
Milestone: 17.01
Summary: I don't knowInaccessibleObjectException with JDK 9 b148+

comment:2 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 11443/josm:

fix #14211, see #11924 - InaccessibleObjectException with JDK 9 b148+

comment:3 Changed 3 years ago by Don-vip

Ticket #14300 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.