Modify

Opened 6 years ago

Closed 6 years ago

#14140 closed defect (duplicate)

ArrayIndexOutOfBoundsException

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Asked to download http://www.openstreetmap.org/relation/4202684 and got this:

2016-12-20 11:06:35.072 INFORMAÇÕES: GET https://api.openstreetmap.org/api/0.6/relations?relations=4202684 -> 200
2016-12-20 11:06:36.496 INFORMAÇÕES: GET https://api.openstreetmap.org/api/0.6/relation/4202684/full -> 200
2016-12-20 11:06:39.253 GRAVE: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 258
java.lang.ArrayIndexOutOfBoundsException: 258
	at org.openstreetmap.josm.data.osm.Storage$SafeReadonlyIter.next(Storage.java:533)
	at org.openstreetmap.josm.tools.SubclassFilteredCollection$FilterIterator.findNext(SubclassFilteredCollection.java:40)
	at org.openstreetmap.josm.tools.SubclassFilteredCollection$FilterIterator.hasNext(SubclassFilteredCollection.java:50)
	at org.openstreetmap.josm.gui.io.AbstractPrimitiveTask.loadIncompleteRelationMembers(AbstractPrimitiveTask.java:124)
	at org.openstreetmap.josm.gui.io.AbstractPrimitiveTask.realRun(AbstractPrimitiveTask.java:111)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at org.openstreetmap.josm.gui.io.DownloadPrimitivesWithReferrersTask.realRun(DownloadPrimitivesWithReferrersTask.java:106)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-12-17 22:13:42 +0100 (Sat, 17 Dec 2016)
Build-Date:2016-12-20 02:32:25
Revision:11407
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11407 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 247 MB / 10206 MB (64 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-3-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-8-jre:amd64-8u111-b14-3
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-11
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (32699)
+ FastDraw (33004)
+ ImportImagePlugin (33028)
+ OpeningHoursEditor (33004)
+ PicLayer (33088)
+ RoadSigns (33088)
+ SimplifyArea (33004)
+ apache-commons (32994)
+ buildings_tools (33004)
+ conflation (0.3.0)
+ contourmerge (1030)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geojson (52)
+ geotools (33042)
+ importvec (33088)
+ indoorhelper (33088)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33004)
+ opendata (33088)
+ pbf (33004)
+ pdfimport (33004)
+ poly (33004)
+ reverter (33088)
+ scripting (30762)
+ tageditor (33021)
+ todo (30000)
+ turnlanes (33088)
+ turnlanes-tagging (254)
+ turnrestrictions (33088)
+ undelete (32699)
+ utilsplugin2 (33088)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- <josm.pref>/styles/indoor.mapcss
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss

Validator rules:
+ /arquivos/git/validador-josm/Rules_Brazilian-Specific.validator.mapcss
+ /arquivos/git/validador-josm/staging.validator.mapcss
- <josm.pref>/validator/indoorhelper.validator.mapcss

Last errors/warnings:
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 258
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@105256bd
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@4e173214
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@4b5da982
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@174a2f5e


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.ArrayIndexOutOfBoundsException: 258
	at org.openstreetmap.josm.data.osm.Storage$SafeReadonlyIter.next(Storage.java:533)
	at org.openstreetmap.josm.tools.SubclassFilteredCollection$FilterIterator.findNext(SubclassFilteredCollection.java:40)
	at org.openstreetmap.josm.tools.SubclassFilteredCollection$FilterIterator.hasNext(SubclassFilteredCollection.java:50)
	at org.openstreetmap.josm.gui.io.AbstractPrimitiveTask.loadIncompleteRelationMembers(AbstractPrimitiveTask.java:124)
	at org.openstreetmap.josm.gui.io.AbstractPrimitiveTask.realRun(AbstractPrimitiveTask.java:111)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at org.openstreetmap.josm.gui.io.DownloadPrimitivesWithReferrersTask.realRun(DownloadPrimitivesWithReferrersTask.java:106)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by naoliv

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14135.
Didn't see #14135
Sorry;.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.