Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14135 closed defect (fixed)

Exception while loading relation with higher ID

Reported by: aighes Owned by: Don-vip
Priority: major Milestone: 16.12
Component: Core Version: latest
Keywords: regression Cc:

Description

What steps will reproduce the problem?

  1. run josm
  2. File -> Download Object
  3. try to download relation with higher ID, eg. 6799987

What is the expected result?

Relation should be downloaded

What happens instead?

While downloading there comes an exception, the relation is only downloaded partly, but can be downloaded later by "download incomplete members"

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-12-17 22:13:42 +0100 (Sat, 17 Dec 2016)
Build-Date:2016-12-19 02:34:30
Revision:11407
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11407 en) Windows 10 64-Bit
Memory Usage: 1295 MB / 7282 MB (386 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (33004)
+ HouseNumberTaggingTool (32699)
+ apache-commons (32994)
+ buildings_tools (33004)
+ ejml (32680)
+ geojson (52)
+ geotools (33042)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ o5m (33088)
+ opendata (33088)
+ pbf (33004)
+ poly (33004)
+ pt_assistant (33091)
+ public_transport (33088)
+ public_transport_layer (33088)
+ reverter (33088)
+ splinex (33007)
+ terracer (33088)
+ undelete (32699)
+ utilsplugin2 (33088)
+ waydownloader (33088)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1

Last errors/warnings:
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.ArrayIndexOutOfBoundsException

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by Don-vip

Reproduced, full stacktrace:

Build-Date:2016-12-20 05:27:40
Revision:11407
Is-Local-Build:true

Identification: JOSM/1.5 (11407 SVN en_GB) Windows 10 64-Bit
Memory Usage: 865 MB / 3614 MB (661 MB allocated, but free)
Java version: 1.8.0_112-b15, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
VM arguments: [-Dfile.encoding=UTF-8]
Program arguments: [--debug]

Plugins:
+ OSMRecPlugin (33013)
+ apache-commons (32994)
+ ejml (32680)
+ geotools (33042)
+ jts (32699)
+ log4j (32699)
+ opendata (33088)
+ utilsplugin2 (33088)

Last errors/warnings:
- W: Invalid jar file ''<josm.pref>\plugins\OSMRecPlugin.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\utilsplugin2.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\apache-commons.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\opendata.jar.new'' (exists: false, canRead: false)
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 64


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.ArrayIndexOutOfBoundsException: 64
	at org.openstreetmap.josm.data.osm.Storage$SafeReadonlyIter.next(Storage.java:533)
	at org.openstreetmap.josm.tools.SubclassFilteredCollection$FilterIterator.findNext(SubclassFilteredCollection.java:40)
	at org.openstreetmap.josm.tools.SubclassFilteredCollection$FilterIterator.hasNext(SubclassFilteredCollection.java:50)
	at org.openstreetmap.josm.gui.io.AbstractPrimitiveTask.loadIncompleteRelationMembers(AbstractPrimitiveTask.java:124)
	at org.openstreetmap.josm.gui.io.AbstractPrimitiveTask.realRun(AbstractPrimitiveTask.java:111)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at org.openstreetmap.josm.gui.io.DownloadPrimitivesWithReferrersTask.realRun(DownloadPrimitivesWithReferrersTask.java:106)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

comment:2 Changed 3 years ago by Don-vip

Keywords: regression added
Milestone: 16.12
Owner: set to Don-vip
Priority: normalmajor
Status: newassigned

comment:3 Changed 3 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 11408/josm:

fix #14135 - regression from r11395

comment:4 Changed 3 years ago by naoliv

Ticket #14140 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.