Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14090 closed defect (fixed)

RelationList dialog causes very severe performance issues

Reported by: nyurik Owned by: team
Priority: normal Milestone: 16.12
Component: Core Version:
Keywords: relationlist performance Cc:

Description (last modified by Don-vip)

In file josm/core/src/org/openstreetmap/josm/gui/dialogs/RelationListDialog.java line 151:

displaylist.addListSelectionListener(e -> updateActionsRelationLists());

Whenever I try to fetch Wikidata IDs for a large set of relations, JOSM freezes, sometimes for hours, with 100% CPU on a single thread. Debugging showed that all the work is being done in the above function. If I close the RelationList dialog, it finishes in seconds. I tried it in 11362 (svn build)

Repo: Install wikipedia plugin, and get 1000+ objects using this query. Select all relations, and "fetch Wikidata IDs" (Data menu).

[out:xml][timeout:50];
(
    relation["wikipedia"]({{bbox}});
);
out meta;

Attachments (0)

Change History (8)

comment:1 Changed 3 years ago by skyper

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/images/bug.png Report Bug.


comment:2 Changed 3 years ago by Klumbumbus

Keywords: performance added

comment:3 Changed 3 years ago by Don-vip

Description: modified (diff)

comment:4 Changed 3 years ago by Don-vip

@skyper: there's enough information in this bug report.

comment:5 Changed 3 years ago by Don-vip

Milestone: 16.11

comment:6 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 11365/josm:

fix #14090 - use DefaultListSelectionModel adjusting selection mode to avoid too much costly listener calls

comment:7 in reply to:  4 Changed 3 years ago by skyper

Replying to Don-vip:

@skyper: there's enough information in this bug report.

Sorry, next time I will not touch a ticket like this. I was not sure if the OS and java version are important.

comment:8 Changed 3 years ago by Don-vip

Milestone: 16.1116.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.