Modify

Opened 3 years ago

Closed 3 years ago

#14020 closed defect (duplicate)

reverter crashes

Reported by: osm@… Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

Trying to revert CS #42904127 using the reverter plugin.

When downloading the object history, the reverter crashes, showing the "unexpected exception" dialog. Tried that several times.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-06 20:18:38 +0100 (Sun, 06 Nov 2016)
Build-Date:2016-11-06 21:45:03
Revision:11223
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11223 de) Linux Debian GNU/Linux 8.6 (jessie)
Memory Usage: 725 MB / 1820 MB (147 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-2~bpo8+1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
Java package: openjdk-8-jre:amd64-8u111-b14-2~bpo8+1
Java ATK Wrapper package: libatk-wrapper-java:all-0.30.5-1
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (32699)
+ FastDraw (32938)
+ PicLayer (32796)
+ alignways (32921)
+ buildings_tools (32944)
+ continuosDownload (53)
+ contourmerge (1030)
+ download_along (32946)
+ livegps (32954)
+ measurement (32936)
+ reverter (32796)
+ terracer (33031)
+ undelete (32699)
+ utilsplugin2 (32815)

Tagging presets:
+ <josm.pref>/eigene-vorlagen.xml

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 2.865.913.134 nicht gefunden
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- E: Handled by bug report queue: java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 2.865.913.134 nicht gefunden
- E: Handled by bug report queue: java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 2.865.913.134 nicht gefunden


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 2.865.913.134 nicht gefunden
	at reverter.DataSetCommandMerger.getMergeTarget(DataSetCommandMerger.java:61)
	at reverter.DataSetCommandMerger.mergeNode(DataSetCommandMerger.java:81)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:172)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:45)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:344)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:110)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13981.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.