Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13950 closed defect (fixed)

user defined shortcut for adjacent ways dont work anymore

Reported by: MKnight Owned by: team
Priority: normal Milestone: 16.12
Component: Core Version:
Keywords: template_report Cc: simon04

Description

What steps will reproduce the problem?

  1. Go to the keyboard-shortcuts
  2. select adjacent ways
  3. uncheck predefined
  4. use E (without shift&co)
  5. (similar changes in adjacent nodes to Shift+E)

What is the expected result?

  1. E should select ways like in older josm-versions

What happens instead?

  1. Nothing, but (after restart):

2.1. in the keyboard-shortcuts is adjacent ways double, one with my change, another with STRG+ALT+F5, STRG+ALT+F5 works, E not
2.2. SHIFT+E for the Nodes works fine like in older Versions

  1. Mark predefined for the Shortcuts again, get STRG+ALT+E for the ways (additional to STRG+ALT+F5)

3.1 Restart: the double entry is gone and for ways is "Shift+E" and for Nodes "E" (standard)

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-06 20:18:38 +0100 (Sun, 06 Nov 2016)
Build-Date:2016-11-06 21:45:03
Revision:11223
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11223 de) Windows 7 64-Bit
Memory Usage: 385 MB / 1305 MB (106 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768, \Display1 1280x1024
Maximum Screen Size: 1366x1024
Program arguments: [de-josm-kreise.joz]
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (11)
+ Mapillary (v1.3.1)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32944)
+ continuosDownload (53)
+ download_along (32946)
+ ejml (32680)
+ geochat (32796)
+ geotools (33042)
+ jogl (1.0.46)
+ jts (32699)
+ kendzi3d (1.0.192)
+ kendzi3d-resources (0.0.1)
+ log4j (32699)
+ measurement (32936)
+ opendata (33049)
+ pbf (32865)
+ public_transport (32796)
+ reltoolbox (32796)
+ reverter (32796)
+ scripting (30761)
+ tag2link (33035)
+ tageditor (33021)
+ terracer (33031)
+ turnlanes (32796)
+ turnlanes-tagging (252)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32815)
+ waydownloader (32699)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Maxspeed-zones&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ http://www.country-linedance.de/daten/Verkehrszeichen-vorlage.zip
+ https://raw.github.com/Flacus/Windrad/master/windrad.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
+ C:\OSm\JOSM\osmic-josm-style-master\osmic.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ C:\OSm\JOSM\eigene-style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by Klumbumbus

Cc: simon04 added

Still a regression of shortcut rework left?

comment:2 Changed 3 years ago by Klumbumbus

Ticket #14011 has been marked as a duplicate of this ticket.

comment:3 Changed 3 years ago by simon04

Milestone: 16.11

comment:4 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 11340/josm:

fix #13950 see #12030 - Custom interchanged shortcuts are broken

comment:5 Changed 3 years ago by Don-vip

Milestone: 16.1116.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.