Modify

Opened 3 years ago

Closed 7 months ago

#13891 closed defect (fixed)

Adding a member to a relation when it is already in a relation moves the selection down

Reported by: Stereo Owned by: team
Priority: normal Milestone: 18.10
Component: Core Version:
Keywords: template_report relation Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Create a relation with members foo, bar, baz
  2. In the relation panel, select foo on the left. Select object baz on the right.
  3. Click the button to add baz to the relation

What is the expected result?

Nothing (or actually a message saying that the member is already in the relation and that you can copy-paste it if you need it twice)

What happens instead?

Selection on the left panel gets moved to foo and bar

Please provide any additional information below. Attach a screenshot if possible.

After

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en_GB) Mac OS X 10.12.1
Memory Usage: 1147 MB / 3641 MB (641 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69731906 1920x1200
Maximum Screen Size: 1920x1200
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true, -Dawt.useSystemAAFontSettings=on, -Dswing.aatext=true, -Dsun.java2d.xrender=true

-Dsun.java2d.xrender=true
]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (32699)
+ CommandLine (32796)
+ DirectDownload (32699)
+ DirectUpload (32699)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ ImportImagePlugin (32699)
+ ImproveWay (9)
+ Mapillary (v1.3.1)
+ OSMRecPlugin (32796)
+ OpenStreetView (22)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ alignways (32921)
+ apache-commons (32699)
+ apache-http (32699)
+ areaselector (282)
+ auto_tools (1471534390)
+ buildings_tools (32944)
+ conflation (0.3.0)
+ contourmerge (1030)
+ download_along (32946)
+ ejml (32680)
+ geotools (33042)
+ gson (32680)
+ imagery-xml-bounds (32699)
+ imagery_offset_db (32796)
+ importvec (32699)
+ jts (32699)
+ livegps (32954)
+ log4j (32699)
+ mapdust (32787)
+ merge-overlap (32699)
+ namemanager (32699)
+ opendata (33040)
+ pdfimport (32796)
+ pt_assistant (32990)
+ public_transport (32796)
+ public_transport_layer (32817)
+ reverter (32796)
+ rex (26)
+ routing (32796)
+ scripting (30761)
+ splinex (32918)
+ surveyor (32796)
+ tageditor (33021)
+ terracer (33031)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32815)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ http://osmtools.de/josm/steps.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/TreeCrownDiameter&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&style&zip=1
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Suburb&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style&zip=1
- http://maps.openstreetmap.ie/josm/townland.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&style&zip=1
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryChangesetDialog$SubmitAction@25862f5a
- W: java.net.SocketTimeoutException: Read timed out
- E: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out
- E: IO Exception - <html>Failed to upload data to or download data from<br>'https://api.openstreetmap.org/api/0.6/relation/2744515/history'<br>due to a problem with transferring data.<br>Details (untranslated): Read timed out</html>
- W: java.net.SocketTimeoutException: Read timed out
- W: Already here java.net.SocketTimeoutException: Read timed out
- E: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out
- E: IO Exception - <html>Failed to upload data to or download data from<br>'https://api.openstreetmap.org/api/0.6/relation/2744515/history'<br>due to a problem with transferring data.<br>Details (untranslated): Read timed out</html>

Attachments (1)

Screen Shot 2016-11-01 at 10.19.41.png (156.5 KB) - added by Stereo 3 years ago.
After

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by Stereo

After

comment:1 Changed 3 years ago by Klumbumbus

Owner: changed from team to Stereo
Status: newneedinfo

For the missing message see #12159.
Regarding the selection I cannot reproduce. When I add an object from the right side to the relation (left side) the new member will be selected then on the left side. Maybe I missunderstood you?

comment:2 Changed 3 years ago by Stereo

You're adding baz when baz is already in the relation?

comment:3 in reply to:  2 Changed 3 years ago by Klumbumbus

Replying to Stereo:

You're adding baz when baz is already in the relation?

Yes.

comment:4 Changed 3 years ago by Stereo

Ahh, #12159 explains many things, thanks!

To reproduce it, you have to say 'no' when it asks you if you want to add that relation member again.

comment:5 Changed 3 years ago by Klumbumbus

So to summarize this:
When choosing "no" and "remember this choice" was set and you try to add a member to the relation (which will not work then) you want that the selection in the left column stays the same. Right?

comment:6 Changed 3 years ago by Stereo

That's right! But after I reset the setting mentioned in #12159 I could reproduce it when choosing 'no' in the dialog - the selection went down one notch.

I assume that the code always goes down one notch when that button is hit, because it assumes that when you hit the button, one element will always be added to the relation.

comment:7 Changed 3 years ago by Klumbumbus

It depends also on which of the 4 add buttons you choose.

comment:8 Changed 3 years ago by Stereo

Ah! Add after last selected member; third button from the top.

comment:9 Changed 2 years ago by Stereo

This is still tagged as 'needinfo'; please let me know if you need anything else.

comment:10 Changed 2 years ago by Klumbumbus

Owner: changed from Stereo to team
Status: needinfonew

comment:5 describes the open "problem"

comment:11 Changed 7 months ago by Don-vip

Description: modified (diff)
Keywords: relation added

comment:12 Changed 7 months ago by Don-vip

Milestone: 18.10

comment:13 Changed 7 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14339/josm:

fix #13891 - don't change selection of relation editor members table when nothing changes

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.