Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13878 closed defect (duplicate)

IAE: {zoom} is not a valid WMS argument

Reported by: daniel.folkeringa@… Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report wms zoom url Cc:

Description

What steps will reproduce the problem?

  1. Open a new imagery proxy-ign.openstreetmap.fr
  2. JOSM asks to open an WMS layer
  3. add layer

then JOSM asks to report a bug

What is the expected result?

Usuallly, the layer imagery layer opens

What happens instead?

Nothing appears on the map. Thou the layers appears in the layer windows

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 fr) Windows 8.1 64-Bit
Memory Usage: 296 MB / 494 MB (136 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1600x900
Maximum Screen Size: 1600x900
Dataset consistency test: No problems found

Plugins:
+ DxfImport (1008)
+ apache-commons (32699)
+ ejml (32680)
+ geojson (43)
+ geotools (32813)
+ jts (32699)
+ measurement (32936)
+ opendata (32898)
+ undelete (32699)
+ utilsplugin2 (32815)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet


=== REPORTED CRASH DATA ===
MapView#layerAdded:
 - layer: WMSLayer [info=ImageryInfo{name='proxy-ign.openstreetmap.fr', countryCode='', url='http://proxy-ign.openstreetmap.fr/bdortho/{zoom}/{x}/{y}.jpg?FORMAT=null&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}', imageryType=WMS}]

LayerManager#fireLayerAdded:
 - listener: org.openstreetmap.josm.gui.MapView[,0,0,948x744,alignmentX=0.0,alignmentY=0.0,border=,flags=0,maximumSize=,minimumSize=java.awt.Dimension[width=10,height=0],preferredSize=]
 - event: LayerAddEvent [addedLayer=WMSLayer [info=ImageryInfo{name='proxy-ign.openstreetmap.fr', countryCode='', url='http://proxy-ign.openstreetmap.fr/bdortho/{zoom}/{x}/{y}.jpg?FORMAT=null&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}', imageryType=WMS}]]

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: {zoom} n'est pas un argument WMS valide. Veuillez vérifier l'adresse : http://proxy-ign.openstreetmap.fr/bdortho/{zoom}/{x}/{y}.jpg?FORMAT=null&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}
	at org.openstreetmap.josm.data.imagery.TemplatedWMSTileSource.checkUrl(TemplatedWMSTileSource.java:349)
	at org.openstreetmap.josm.gui.layer.WMSLayer.getTileSource(WMSLayer.java:85)
	at org.openstreetmap.josm.gui.layer.WMSLayer.getTileSource(WMSLayer.java:38)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.initializeIfRequired(AbstractTileSourceLayer.java:697)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.attachToMapView(AbstractTileSourceLayer.java:678)
	at org.openstreetmap.josm.gui.MapView.layerAdded(MapView.java:652)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerAdded(LayerManager.java:379)
	at org.openstreetmap.josm.gui.layer.LayerManager.realAddLayer(LayerManager.java:191)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realAddLayer(MainLayerManager.java:267)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$addLayer$0(LayerManager.java:180)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:180)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:72)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Don-vip

Component: CoreCore imagery
Keywords: wms zoom url added

comment:2 Changed 4 years ago by Don-vip

Summary: JOSM said to report a problemIAE: {zoom} is not a valid WMS argument

comment:3 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13828.

comment:4 Changed 4 years ago by wiktorn

Can you be more precise about your first step:

1. Open a new imagery proxy-ign.openstreetmap.fr 

?

When I choose from menu Imagery/BDOrtho IGN JOSM doesn't ask for adding WMS. Can you elaborate what exactly you're doing?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.