Modify

Opened 3 years ago

Closed 3 years ago

#13821 closed defect (fixed)

Opendata plugin not opening spreadsheet

Reported by: nick-tallguy Owned by: nick-tallguy
Priority: normal Milestone:
Component: Plugin opendata Version:
Keywords: template_report Cc:

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

  1. Install Opendata plugin
  2. From JOSM, file / open, and select .ods or any format of spreadsheet

What is the expected result?

Spreadsheet opens as new data layer in josm

What happens instead?

Error report appears on JOSM screen

Please provide any additional information below. Attach a screenshot if possible.

On the same laptop I booted into Windows 7 and then installed new josm from fresh download of .exe from site. Fresh install of java - from oracle site. Same result - unable to open spreadsheet.

I've been trying for 2 days - sometimes the data appears, but is obviously distorted - instead of the points appearing as a roughly even 'round' shape, they appear as a column. I have used this spreadsheet before to input data, but this was on and around the 21/06/2016 and presumably both my java & josm files are new versions.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en_GB) Linux Mint 18 Sarah
Memory Usage: 250 MB / 1730 MB (63 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-3ubuntu1~16.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
Java package: openjdk-8-jre:amd64-8u91-b14-3ubuntu1~16.04.1
WebStart package: icedtea-netx:amd64-1.6.2-3ubuntu1
VM arguments: [-Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/bin/javaws, -Djava.security.manager, -Djava.security.policy=/etc/icedtea-web/javaws.policy]

Plugins:
+ apache-commons (32699)
+ buildings_tools (32944)
+ ejml (32680)
+ geotools (32813)
+ jts (32699)
+ opendata (32898)
+ todo (30000)
+ utilsplugin2 (32815)

Map paint styles:
+ https://github.com/hotosm/HDM-JOSM-style/archive/master.zip

Last errors/warnings:
- E: null is NOT valid
- E: Reason: cvc-elt.1: Cannot find the declaration of element 'Workbook'.
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@79ccbc6e
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@4fe6740e
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@168c8f46
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@4d8a93a9
- W: Skipping line 2 because no valid coordinates have been found at columns CoordinateColumns [proj=WGS84 Geographic, xCol=2, yCol=2]
- W: Skipping line 2 because no valid coordinates have been found at columns CoordinateColumns [proj=WGS84 Geographic, xCol=2, yCol=2]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (21) of JOSM
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.SpreadSheetReader.doParse(SpreadSheetReader.java:234)
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.SpreadSheetReader.parse(SpreadSheetReader.java:279)
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.OdsReader.parseDataSet(OdsReader.java:35)
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.OdsImporter.parseDataSet(OdsImporter.java:29)
	at org.openstreetmap.josm.io.OsmImporter.loadLayer(OsmImporter.java:113)
	at org.openstreetmap.josm.io.OsmImporter.importData(OsmImporter.java:90)
	at org.openstreetmap.josm.plugins.opendata.core.io.AbstractImporter.importData(AbstractImporter.java:55)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:90)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:349)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:274)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (1)

1_set_v_0.6_2016_06_21_06_00_23_a.ods (21.3 KB) - added by nick-tallguy 3 years ago.
One of the spreadsheets which fails to load - all worked ok in June. Sorry about delay, didn't notice the request. I have other spreadsheets in series if needed.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 3 years ago by Klumbumbus

Component: CorePlugin opendata
Description: modified (diff)
Owner: changed from team to Don-vip

comment:2 Changed 3 years ago by Don-vip

Owner: changed from Don-vip to nick-tallguy
Status: newneedinfo

I need your input file to investigate, can you please attach it to this ticket?

Changed 3 years ago by nick-tallguy

One of the spreadsheets which fails to load - all worked ok in June. Sorry about delay, didn't notice the request. I have other spreadsheets in series if needed.

comment:3 Changed 3 years ago by nick-tallguy

Have installed latest version of JOSM, and still fails to load.

Thanks for looking into this.

comment:4 Changed 3 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

Fixed in [o33049:33050].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nick-tallguy.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.