Modify

Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#13739 closed defect (duplicate)

Unable to continue upload

Reported by: christiaanjoubert2@… Owned by: team
Priority: major Milestone:
Component: Plugin sds Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en) Windows 7 64-Bit
Memory Usage: 568 MB / 989 MB (83 MB allocated, but free)
Java version: 1.8.0_74-b02, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1600x900
Maximum Screen Size: 1600x900
Dataset consistency test: No problems found

Plugins:
+ CADTools (1006)
+ ColorPlugin (1414145445)
+ CommandLine (32796)
+ CustomizePublicTransportStop (0.3)
+ DirectDownload (32699)
+ DirectUpload (32699)
+ ElevationProfile (32868)
+ FastDraw (32938)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ ImageWayPoint (32699)
+ ImportImagePlugin (32699)
+ ImproveWay (1452443304)
+ Mapillary (v1.3.1)
+ OpenStreetView (22)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ SeaChart (32995)
+ SeaMapEditor (32767)
+ ShapeTools (1220)
+ TombPlugin (50)
+ apache-commons (32699)
+ apache-http (32699)
+ auto_tools (1471534390)
+ buildings_tools (32944)
+ colorscheme (32699)
+ continuosDownload (53)
+ contourmerge (1022)
+ dataimport (32699)
+ download_along (32946)
+ ejml (32680)
+ fieldpapers (v0.4.0)
+ geochat (32796)
+ geotools (32813)
+ globalsat (32796)
+ gpsblam (32745)
+ gson (32680)
+ imagery_offset_db (32796)
+ imageryadjust (32699)
+ indoor_sweepline (32796)
+ indoorhelper (32680)
+ jogl (1.0.46)
+ jts (32699)
+ lakewalker (32699)
+ log4j (32699)
+ mapdust (32787)
+ merge-overlap (32699)
+ openvisible (32796)
+ osm-obj-info (1468276210)
+ osmarender (32699)
+ pbf (32865)
+ print (32699)
+ pt_assistant (32990)
+ public_transport (32796)
+ public_transport_layer (32817)
+ rasterfilters (32877)
+ reltoolbox (32796)
+ reverter (32796)
+ rex (1928)
+ routes (32842)
+ scripting (30741)
+ sds (32796)
+ splinex (32918)
+ tageditor (33021)
+ todo (30000)
+ turnlanes (32796)
+ turnlanes-tagging (252)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32815)
+ wikipedia (33017)

Last errors/warnings:
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NullPointerException
	at org.openstreetmap.hot.sds.DetermineSdsModificationsUploadHook.checkUpload(DetermineSdsModificationsUploadHook.java:67)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:207)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:231)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:271)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 21 months ago by Klumbumbus

Component: CorePlugin sds
Resolution: duplicate
Status: newclosed

Closed as duplicate of #13613.

comment:2 Changed 21 months ago by Klumbumbus

It seems you installed all plugins. Do you really need them all? It could be a good idea to disable the plugins you don't need.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.