Modify

Opened 3 years ago

Closed 3 years ago

#13705 closed enhancement (wontfix)

Coloured Streets adress on way without building-tag

Reported by: rza31 Owned by: team
Priority: normal Milestone:
Component: External mappaint style Version:
Keywords: Cc: Klumbumbus

Description

This way https://www.openstreetmap.org/way/309421880
is without building-tag.

The adress is not visible on the map.
At the moment you don't see in JOSM the missing building=yes by coloured streets style.

My suggestion create a different colour like "highway without name" by missing building on way with adress.

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by skyper

Cc: Klumbumbus added

For external styles, rules, plugins and presets you are better of by contacting the author(s). Have a look at the style's wiki page wiki page.

comment:2 Changed 3 years ago by Klumbumbus

This is the intended behavior. A closed way with an address doesn't need to be a building. You can't for sure know if the bulding tag is missing or not.

Examples:

comment:3 Changed 3 years ago by Klumbumbus

I created an overpass query to find missing building keys, but it still creates false positives: http://overpass-turbo.eu/s/iA7

comment:4 Changed 3 years ago by Klumbumbus

https://www.openstreetmap.org/way/174998828 - bulding missing
https://www.openstreetmap.org/way/186961964 - building not missing

however both have basically the same tags

comment:5 in reply to:  3 Changed 3 years ago by Klumbumbus

Replying to Klumbumbus:

I created an overpass query to find missing building keys, but it still creates false positives: http://overpass-turbo.eu/s/iA7

We could implemet this as validator test, however only at info level due to the false positives.

comment:6 Changed 3 years ago by rza31

The overpass query for false positive validation is a good idea.

Your examples:

Look in JOSM to the NRW-Alkis- or MAPS4BW-layer the addresses are always placed to the building.

comment:7 Changed 3 years ago by Klumbumbus

For sites with several buildings it makes sense to put the address on the property outline. See e.g. https://www.openstreetmap.org/way/164779980. It doesn't make sense to put the same address to all the single buildings within the site. Also it doesn't make sense to put the address to only one of the buildings.

Also (atleast in germany) the address belongs to the property not to the building. And properties without a building can have an address. (see https://de.wikipedia.org/wiki/Hausnummer#Deutschland_2 „Der Eigentümer hat sein Grundstück mit der von der Gemeinde festgesetzten Nummer zu versehen.“) Since we usually don't map properties in osm it makes sense in most cases to put the address on the building.

Last edited 3 years ago by Klumbumbus (previous) (diff)

comment:8 Changed 3 years ago by Klumbumbus

In 11080/josm:

see #13705 - add warning about possibly missing building tag (info level)

comment:9 Changed 3 years ago by Klumbumbus

Resolution: wontfix
Status: newclosed

It's part of the validator now. For Coloured Streets I don't see a good solution for this as the style focuses only on addresses and not on other tags.

Beside the false positives it is also not always the building tag which is missing but e.g. landuse=farmyard like in this example: https://pewu.github.io/osm-history/#/way/39043341 (version 6)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.