Modify

Opened 13 years ago

Closed 12 years ago

#1361 closed defect (fixed)

[PATCH] Relation dialog: "Download inclomplete..." blocks JOSM if OSM does not respond

Reported by: geoj@… Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: relation editor Cc: Gubaer

Description

Sometimes download requests to the OSM server can take quite a long time. The usual download dialog allows therefore to cancel requests, but not the relation editor dialog. If you execute the function "Download all incomplete ways and nodes in relation" JOSM is blocked until the OSM server sends a result.

I strongly recommend using the download dialog here as well, therefore the user can decide to cancel a request and try again later or just continue the current edit.

I already had the case that I had to kill JOSM because of this problem. Luckily all modifications were already committed...

Attachments (2)

1361-setAlwaysOnTop.patch (697 bytes) - added by Michi 12 years ago.
1361-showMessagedialog.patch (495 bytes) - added by Michi 12 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by Michi

This just happend to me. Not because the download stalled, but because I had some conflicts after downloading. The relation dialog is topmost (at least on Windows), so the modal conflict message box is behind the window. And since it is modal, I could not move the relation editor window away.

I thought I lost my work (> 800 changes to the DB), but I managed to confirm the conflict message by pressing ESC. Phew! ;-)

So, my suggestion is to disable the topmost feature of the realtion editor window, or at least disabling it while downloading missing relation members.

Changed 12 years ago by Michi

Attachment: 1361-setAlwaysOnTop.patch added

Changed 12 years ago by Michi

comment:2 Changed 12 years ago by Michi

I just looked at the sources, and I think there is an nicer solution than setting topmost to false: Not using the parent window as parentComponent. But since I'm not very versed with Java, I'm not sure if that works. So I attached a patch for both of my resolutions.

comment:3 Changed 12 years ago by stoecker

Summary: Relation dialog: "Download inclomplete..." blocks JOSM if OSM does not respond[PATCH] Relation dialog: "Download inclomplete..." blocks JOSM if OSM does not respond

comment:4 Changed 12 years ago by stoecker

Ticket #2876 has been marked as a duplicate of this ticket.

comment:5 Changed 12 years ago by Gubaer

Cc: Gubaer added
Resolution: fixed
Status: newclosed

fixed in r1764

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.