Modify

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#13596 closed defect (fixed)

The plugin "openinghourseditor" can not edit an existing data again

Reported by: vdmfrankvdm@… Owned by: boman
Priority: major Milestone:
Component: Plugin openinghourseditor Version:
Keywords: regression Cc: naoliv, Smarties

Description (last modified by Don-vip)

Selecting a tag that contains openings hours then opening the plugin openingshourseditor the plugin do not import the already present day time ect. Even if it is good or bad. Before, You could verify if it was good when it shows in the editor, if wrong you saw a error.

Using from scratch in a blank emty new tag works.


Attachments (2)

openingshours1.jpg (142.7 KB) - added by anonymous 3 years ago.
opening_hours_issue.ogv (449.9 KB) - added by Mkyral 2 years ago.
Editing issue - video

Download all attachments as: .zip

Change History (17)

Changed 3 years ago by anonymous

Attachment: openingshours1.jpg added

comment:1 Changed 3 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 3 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 3 years ago by skyper

Keywords: regression added; Openingshours plugin removed

comment:4 Changed 3 years ago by aceman

Confirming.

comment:5 in reply to:  4 Changed 3 years ago by vdmfrankvdm@…

Replying to aceman:

Confirming.

@aceman what must I "Confirm" ?
Still do not work ?

comment:6 Changed 3 years ago by aceman

You do not need to do anything. I confirm that I also see the bug on my machine, independently. My JOSM is in a different language so localization should not be the problem. Probably something changed in JOSM code in the recent flow of reworks and the plugin needs an update.

comment:7 Changed 3 years ago by naoliv

Cc: naoliv added

comment:8 Changed 3 years ago by Florian_G

For your information, I have the same problem.

comment:9 Changed 3 years ago by skyper

Ticket #14192 has been marked as a duplicate of this ticket.

comment:10 Changed 3 years ago by skyper

Cc: Smarties added
Priority: normalmajor

comment:11 Changed 3 years ago by Smarties

Summary: Plugin openinghourseditor do not work good anymoreThe plugin "openinghourseditor" can not edit an existing data again

What steps will reproduce the problem?

  • The plugin opening_hours can not edit an existing opening_hours again.

What is the expected result?

  • To open the Editor and change existing opening_hours.

What happens instead?

  • If you open an existing opening_hours the plugin will show a grey blank field like 24/7.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-01-02 00:53:29 +0100 (Mon, 02 Jan 2017)
Build-Date:2017-01-02 02:33:21
Revision:11427
Relative:URL: /trunk

Identification: JOSM/1.5 (11427 de) Windows 8.1 64-Bit
Memory Usage: 224 MB / 989 MB (87 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1200
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (33004)
+ OpeningHoursEditor (33004)
+ download_along (32946)
+ indoor_sweepline (33007)
+ indoorhelper (33088)
+ measurement (33088)
+ utilsplugin2 (33088)
+ waydownloader (33088)
+ wikipedia (33098)

Map paint styles:

Last errors/warnings:

  • W: Unable to get color from for color preference 'extrude.main.line'
  • W: Unable to get color from for color preference 'improve.way.accuracy.helper.line'
  • W: Unable to get color from for color preference 'make.parallel.helper.line'

comment:12 Changed 2 years ago by mrpulley

I have had the same problem for some time, using JOSM.jar on a Mac. (So it's not just a Windows problem.)

comment:13 Changed 2 years ago by Mkyral

I'm using JOSM on linux and it happen to me as well. I noticed it several weeks ago as usually I'm only addin a missing opening hours, not editing existing one.

There is no error message in console. As soon as there is some value in the Value field, the grif below is not shown. When I delete the value and confirm it by pressing Enter, grid is show. Also click on 24/7 button causes that grid is deleted and there is only gray area.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-04 17:52:07 +0100 (Sat, 04 Feb 2017)
Build-Date:2017-02-05 02:33:05
Revision:11540
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11540 cs) Linux Gentoo
Memory Usage: 1759 MB / 3547 MB (480 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dawt.useSystemAAFontSettings=on, -Dswing.aatext=true]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (32699)
+ DirectUpload (32885)
+ OpeningHoursEditor (33004)
+ PicLayer (33088)
+ Tracer-testing (33004)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ contourmerge (1030)
+ dataimport (33024)
+ editgpx (33004)
+ ejml (32680)
+ geotools (33042)
+ imagery_offset_db (33004)
+ jts (32699)
+ log4j (32699)
+ opendata (33088)
+ pointInfo (33131)
+ pt_assistant (33108)
+ reltoolbox (33088)
+ reverter (33088)
+ turnrestrictions (33088)
+ utilsplugin2 (33124)
+ wikipedia (33098)

Changed 2 years ago by Mkyral

Attachment: opening_hours_issue.ogv added

Editing issue - video

comment:14 Changed 2 years ago by Don-vip

Ticket #14365 has been marked as a duplicate of this ticket.

comment:15 Changed 2 years ago by stoecker

Resolution: fixed
Status: newclosed

Fixed in [o33185:33186].

Last edited 2 years ago by stoecker (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain boman.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.