Modify

Opened 4 years ago

Last modified 4 years ago

#13589 reopened defect

IAE: Cannot paint layer, it is not registered (ElevationProfileLayer)

Reported by: anonymous Owned by: OliverW
Priority: normal Milestone:
Component: Plugin elevationprofile Version:
Keywords: template_report regression gsoc-core Cc: michael2402

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-08 01:17:53 +0200 (Thu, 08 Sep 2016)
Build-Date:2016-09-08 01:35:41
Revision:10976
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10976 en) Linux Mint 18 Sarah
Memory Usage: 337 MB / 697 MB (61 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-3ubuntu1~16.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1024x768
Maximum Screen Size: 1024x768
Java package: openjdk-8-jre:amd64-8u91-b14-3ubuntu1~16.04.1

Plugins:
+ CADTools (1006)
+ ColorPlugin
+ CustomizePublicTransportStop (0.3)
+ DxfImport (1008)
+ ElevationProfile (32868)
+ HouseNumberTaggingTool (32699)
+ ImageWayPoint (32699)
+ ImportImagePlugin (32699)
+ ImproveWay (1452443304)
+ Mapillary (32882)
+ NanoLog (32699)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ ShapeTools (1220)
+ TombPlugin
+ alignways (32921)
+ apache-commons (32699)
+ apache-http (32699)
+ auto_tools (1471534390)
+ buildings_tools (32944)
+ cadastre-fr (32796)
+ colorscheme (32699)
+ conflation
+ dataimport (32699)
+ download_along (32946)
+ editgpx (32699)
+ ejml (32680)
+ ext_tools (32796)
+ geojson (43)
+ geotools (32813)
+ gpxfilter (32699)
+ gson (32680)
+ imagery-xml-bounds (32699)
+ imagery_offset_db (32796)
+ imageryadjust (32699)
+ importvec (32699)
+ indoor_sweepline (32796)
+ indoorhelper (32680)
+ jna (32699)
+ jogl (1.0.46)
+ jts (32699)
+ kendzi3d-resources (0.0.1)
+ kendzi3d_Improved_by_Andrei
+ lakewalker (32699)
+ log4j (32699)
+ mapdust (32787)
+ measurement (32936)
+ o5m (32857)
+ opendata (32898)
+ openvisible (32796)
+ osm-obj-info (1468276210)
+ osmarender (32699)
+ pbf (32865)
+ pdfimport (32796)
+ photo_geotagging (32699)
+ photoadjust (32863)
+ print (32699)
+ pt_assistant (32895)
+ public_transport (32796)
+ public_transport_layer (32817)
+ rasterfilters (32877)
+ reltoolbox (32796)
+ reverter (32796)
+ rex
+ splinex (32918)
+ tag2link (32941)
+ tageditor (32796)
+ tagging-preset-tester (32869)
+ terracer (32699)
+ tofix (267)
+ undelete (32699)
+ utilsplugin2 (32815)
+ walkingpapers (32796)
+ waydownloader (32699)
+ waypoint_search (32699)
+ wikipedia (32884)

Tagging presets:
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/AdvertisingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Leaftype&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Light_sources&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ http://somewhere.dk/email/josm/source.xml
+ http://osmtools.de/josm/steps.xml
+ https://raw.github.com/Flacus/Windrad/master/windrad.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Trees&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Animal_facilities&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/SentieriItaliani&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/IRS&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/MobilePhoneBaseStations&zip=1
+ http://openstationmap.org/latest/JOSM-preset-OpenStationMap-LoD.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ http://www.openrailwaymap.org/josm-presets/de.zip
+ http://www.openrailwaymap.org/josm-presets/at-signals-v2.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/TreeCrownDiameter&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&zip=1
- <josm.pref>/styles/indoor.mapcss
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Schools&zip=1

Validator rules:
+ <josm.pref>/validator/indoorhelper.validator.mapcss

Last errors/warnings:
- W: Ext_Tools warning: can not load file <josm.pref>/plugins/ext_tools/repo.cfg
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin ColorPlugin. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoSuchMethodError: andrei.josm.plugin.color.ColorAction.getCurrentDataSet()Lorg/openstreetmap/josm/data/osm/DataSet;
- W: Disable plugin - Could not load plugin ColorPlugin. Delete from preferences?
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin TombPlugin. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoSuchMethodError: kendzi.josm.plugin.tomb.action.TombAction.getCurrentDataSet()Lorg/openstreetmap/josm/data/osm/DataSet;
- W: Disable plugin - Could not load plugin TombPlugin. Delete from preferences?
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin conflation. Cause: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/MapView$EditLayerChangeListener. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.MapView$EditLayerChangeListener
- W: Disable plugin - Could not load plugin conflation. Delete from preferences?
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.tofix.TofixDialog$3@7d6e2251
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.tofix.TofixDialog$4@2e958f46
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.tofix.TofixDialog$5@ff77426


=== REPORTED CRASH DATA ===
MapView#paintLayer:
 - layer: ElevationProfileLayer [name=Elevation Profile, associatedFile=null]
 - bounds: Bounds[48.8723943,2.155163,48.9097225,2.2194823]

Warning issued by: MapView#paintLayer

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:427)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:527)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:290)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (8)

comment:1 Changed 4 years ago by Klumbumbus

Component: CoreCore mappaint
Summary: Windows WarningsIllegalArgumentException: Cannot paint layer, it is not registered.

comment:2 Changed 4 years ago by Don-vip

Component: Core mappaintPlugin elevationprofile
Owner: changed from team to OliverW

comment:3 Changed 4 years ago by Don-vip

Cc: michael2402 added
Keywords: regression gsoc-core added

comment:4 Changed 4 years ago by simon04

Resolution: duplicate
Status: newclosed
Summary: IllegalArgumentException: Cannot paint layer, it is not registered.IllegalArgumentException: Cannot paint layer, it is not registered. (ElevationProfileLayer)

Closed as duplicate of #13503.

comment:5 Changed 4 years ago by simon04

Resolution: duplicate
Status: closedreopened

comment:6 Changed 4 years ago by skyper

Similar to #14076

comment:7 Changed 4 years ago by Don-vip

Summary: IllegalArgumentException: Cannot paint layer, it is not registered. (ElevationProfileLayer)IAE: Cannot paint layer, it is not registered (ElevationProfileLayer)

comment:8 Changed 4 years ago by Don-vip

Ticket #14076 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain OliverW.
as The resolution will be set.
to The owner will be changed from OliverW to the specified user.
The owner will change to anonymous
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.