Modify

Opened 3 years ago

Closed 3 years ago

#13500 closed defect (duplicate)

Validator doesn't detect some self-intersecting ways

Reported by: mdk Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open SelfInterception.osm
  2. Validate

What is the expected result?

Warning about self intersecting way

What happens instead?

no warning

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-24 01:34:10 +0200 (Wed, 24 Aug 2016)
Build-Date:2016-08-24 01:32:30
Revision:10888
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10888 en) Linux Ubuntu 15.10
Memory Usage: 468 MB / 876 MB (118 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-3ubuntu1~15.10.1-b14, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-8-jre:i386-8u91-b14-3ubuntu1~15.10.1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-3
VM arguments: [-Djosm.restart=true, -Djosm.home=<josm.pref>, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ ColumbusCSV (32796)
+ FastDraw (32773)
+ HouseNumberTaggingTool (32699)
+ OpeningHoursEditor (32699)
+ RoadSigns (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32796)
+ contourmerge (1021)
+ imagery-xml-bounds (32699)
+ imagery_offset_db (32796)
+ pbf (32865)
+ poly (32699)
+ public_transport (32796)
+ reltoolbox (32796)
+ reverter (32796)
+ terracer (32699)
+ turnlanes (32796)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Unable to remove primitives from TestError [tester=MapCSSTagCheckerAndRule [rule=GroupedMapCSSRule [selectors=[*[building][building'NREGEX'no|entrance][ParameterFunction~equal(class java.lang.Object ArrayFunction~any(class java.lang.Object ParameterFunction~tag(class org.openstreetmap.josm.gui.mappaint.Environment <layer>),class java.lang.Object <0>),class java.lang.Object ArrayFunction~any(class java.lang.Object ParameterFunction~parent_tag(class org.openstreetmap.josm.gui.mappaint.Environment <layer>),class java.lang.Object <0>))] >LinkSelector{conditions=null} *[building][building'NREGEX'no|entrance]], declaration=Declaration [instructions=[throwWarning: ArrayFunction~tr(class java.lang.String <Building inside building>);], idx=8]]], code=3000, message=Building inside building]. java.lang.UnsupportedOperationException

Attachments (1)

SelfInterception.osm (818 bytes) - added by mdk 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by mdk

Attachment: SelfInterception.osm added

comment:1 Changed 3 years ago by GerdP

I don't know why, but the CrossingWays test is only performed for selected tags, e.g. highway, railway, and waterway, and some others, but not for natural=scrub. As far as I know self-intersecting ways are never valid in OSM.

comment:2 Changed 3 years ago by naoliv

Maybe #12843, #13086 and others should all be grouped in a single ticket (they are all about the same problem, it seems)

comment:3 Changed 3 years ago by Don-vip

Priority: majornormal
Summary: [Regression] Validator didn't detect self intersecting waysValidator doesn't detect some self-intersecting ways

comment:4 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13086.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.