Modify

Opened 3 years ago

Closed 3 years ago

#12843 closed defect (duplicate)

Validator didn't detect self-intersecting way

Reported by: mdk Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. open intersecting.osm
  2. validate

What is the expected result?

warning about self intersecting way

What happens instead?

no warning

Please provide any additional information below. Attach a screenshot if possible.

Other intersections are detected, so the example must be a speccial case.
Last stable (r10168) has same problem.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-05-15 01:13:25 +0200 (Sun, 15 May 2016)
Build-Date:2016-05-15 01:32:33
Revision:10213
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10213 en) Linux Ubuntu 15.10
Memory Usage: 346 MB / 876 MB (229 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-0ubuntu4~15.10.1-b14, Oracle Corporation, OpenJDK Server VM
VM arguments: [-Djosm.restart=true, -Djosm.home=<josm.pref>, -Djava.net.useSystemProxies=true]

Plugins:
- ColumbusCSV (32158)
- FastDraw (32158)
- HouseNumberTaggingTool (31926)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- RoadSigns (32177)
- SimplifyArea (32158)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- contourmerge (1014)
- imagery-xml-bounds (32158)
- imagery_offset_db (32158)
- pbf (32158)
- poly (32158)
- public_transport (32158)
- reltoolbox (32158)
- reverter (32158)
- terracer (32158)
- turnlanes (32158)
- turnrestrictions (32158)
- utilsplugin2 (32158)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1

Last errors/warnings:
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <IDENT> "preset "" at line 1, column 19.
- W: Failed to parse Mappaint styles from 'https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1'. Error was: Reached end of file while parsing
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Reached end of file while parsing
- W: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1 completed in 8 ms (2 errors, 0 warnings)

Attachments (2)

intersection.osm (756 bytes) - added by mdk 3 years ago.
intersecting MP.osm (1.3 KB) - added by mdk 3 years ago.
Intersecting multipolygon ways are detected.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by mdk

Attachment: intersection.osm added

comment:1 in reply to:  description Changed 3 years ago by Don-vip

Replying to mdk:

Other intersections are detected, so the example must be a speccial case.

Do other cases have a node at the intersection?

I couldn't detect the error with old JOSM versions in the range r8800 - r9979, it's not a recent regression.

comment:2 Changed 3 years ago by mdk

Hmmmm...
I would sware, that I get warnings about intersections without intersection node in the past, but you are right. I am not able to find a case without an intersection node. Perhaps I'm confused with warnings from keeprigth or OSMInspector.
Is the intersection test written as MapCSS rule? Does the pre MapCSS code also miss this case?

Changed 3 years ago by mdk

Attachment: intersecting MP.osm added

Intersecting multipolygon ways are detected.

comment:3 Changed 3 years ago by mdk

see also #13086

comment:4 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13086.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.