Modify

Opened 5 years ago

Closed 4 years ago

#13416 closed defect (duplicate)

NPE in JCSCachedTileLoaderJob.ensureCacheElement while downloading OSM data

Reported by: mcepl@… Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report jcs cache Cc: wiktorn

Description

What steps will reproduce the problem?

  1. download GPX track
  2. activate Download OSM data

What is the expected result?

dialog for the selection of area shows up

What happens instead?

on the top of that dialog, the error message shows up

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en) Linux Employee SKU
Memory Usage: 147 MB / 2567 MB (34 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1.8.0-openjdk:x86_64-1.8.0.102
WebStart package: icedtea-web:x86_64-1.6.2
VM arguments: [-Dicedtea-web.bin.name=javaws.itweb, -Dicedtea-web.bin.location=/usr/bin/javaws.itweb]
Dataset consistency test: No problems found

Last errors/warnings:
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- W: Failed to persist preferences to '<josm.pref>/preferences.xml' java.io.FileNotFoundException: <josm.pref>/preferences.xml_tmp (No such file or directory)
- W: Failed to persist preferences to '<josm.pref>/preferences.xml' java.io.FileNotFoundException: <josm.pref>/preferences.xml_tmp (No such file or directory)
- W: Failed to persist preferences to '<josm.pref>/preferences.xml' java.io.FileNotFoundException: <josm.pref>/preferences.xml_tmp (No such file or directory)
- W: Failed to persist preferences to '<josm.pref>/preferences.xml' java.io.FileNotFoundException: <josm.pref>/preferences.xml_tmp (No such file or directory)
- W: Failed to persist preferences to '<josm.pref>/preferences.xml' java.io.FileNotFoundException: <josm.pref>/preferences.xml_tmp (No such file or directory)
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (21) of JOSM
java.lang.NullPointerException
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.ensureCacheElement(JCSCachedTileLoaderJob.java:135)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:224)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by Don-vip

Ticket #13417 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by Don-vip

Cc: wiktorn added
Component: CoreCore imagery
Keywords: jcs cache added
Summary: Downloading OSM dataNPE in SCSCachedTileLoaderJob.ensureCacheElement while downloading OSM data

comment:3 Changed 5 years ago by Don-vip

Summary: NPE in SCSCachedTileLoaderJob.ensureCacheElement while downloading OSM dataNPE in JCSCachedTileLoaderJob.ensureCacheElement while downloading OSM data
Version: latest

comment:4 Changed 5 years ago by Don-vip

In 10877/josm:

see #13416 - add parameter validation do detect NPE origin

comment:5 Changed 5 years ago by Don-vip

If you reproduce the error with new JOSM latest, can you please post the new stacktrace?

comment:6 in reply to:  5 Changed 5 years ago by mcepl@…

Replying to Don-vip:

If you reproduce the error with new JOSM latest, can you please post the new stacktrace?

More recent than what I have in #13416? That was the latest like a week ago.

comment:7 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13786.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.