Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13392 closed defect (fixed)

NoClassDefFoundError: org/openstreetmap/josm/data/osm/visitor/paint/LineClip

Reported by: Glassman Owned by: team
Priority: normal Milestone:
Component: Plugin routes Version:
Keywords: template_report regression gsoc-core proguard Cc: michael2402

Description

What steps will reproduce the problem?

  1. Opened JOSM
  2. Used Tasking Manager to open new layer in JOSM
  3. Crash report.

What is the expected result?

Able to start editing

What happens instead?

Received unexpected exception report

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-18 19:51:12 +0200 (Thu, 18 Aug 2016)
Build-Date:2016-08-18 17:56:08
Revision:10842
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10842 en) Linux Fedora release 24 (Twenty Four)
Memory Usage: 915 MB / 7150 MB (700 MB allocated, but free)
Java version: 1.8.0_101-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1.8.0-openjdk:x86_64-1.8.0.101
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (32699)
+ InfoMode (32789)
+ Mapillary (32796)
+ OpeningHoursEditor (32699)
+ alignways (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32796)
+ ejml (32680)
+ geochat (32796)
+ geotools (32813)
+ jts (32699)
+ lakewalker (32699)
+ log4j (32699)
+ opendata (32811)
+ pbf (32699)
+ pdfimport (32796)
+ public_transport (32796)
+ routes (32827)
+ splinex (32796)
+ undelete (32699)
+ utilsplugin2 (32815)
+ wikipedia (32829)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryChangesetDialog$SubmitAction@4dffd1ec


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/osm/visitor/paint/LineClip
	at org.openstreetmap.josm.plugins.routes.paint.AbstractLinePainter.drawSegment(AbstractLinePainter.java:156)
	at org.openstreetmap.josm.plugins.routes.paint.AbstractLinePainter.getPath(AbstractLinePainter.java:132)
	at org.openstreetmap.josm.plugins.routes.paint.NarrowLinePainter.drawWay(NarrowLinePainter.java:48)
	at org.openstreetmap.josm.plugins.routes.RouteLayer.paint(RouteLayer.java:136)
	at org.openstreetmap.josm.gui.layer.AbstractMapViewPaintable$CompatibilityModeLayerPainter.paint(AbstractMapViewPaintable.java:27)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:843)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:935)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:290)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:227)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:227)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1671)
	at java.awt.Component.setVisible(Component.java:1623)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor.lambda$doBeginTask$2(PleaseWaitProgressMonitor.java:186)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.osm.visitor.paint.LineClip
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 59 more

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by anonymous

same result in version 10852.

comment:2 Changed 3 years ago by Don-vip

Cc: michael2402 added
Keywords: regression gsoc-core proguard added

comment:3 Changed 3 years ago by Don-vip

Summary: unexpected error occureredNoClassDefFoundError: org/openstreetmap/josm/data/osm/visitor/paint/LineClip

comment:4 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o32842:32843].

comment:5 Changed 3 years ago by Don-vip

In 10858/josm:

see #13306, see #13392 - remove Main.isOpenJdk, not used anymore

comment:6 Changed 3 years ago by Don-vip

Component: CorePlugin routes

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.