Modify

Opened 3 years ago

Closed 3 years ago

#13238 closed defect (fixed)

Error when updating the gpsblam plugin

Reported by: bgirardot Owned by: team
Priority: major Milestone:
Component: Plugin gpsblam Version:
Keywords: template_report gsoc-core Cc: michael2402

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. have the gpsblam plugin installed
  2. quit josm and get message gpsblam plugin caused an error
  3. select 'update plugin' on dialog box

What is the expected result?

update the plugin or give notice i have the most update version

What happens instead?

josm exception

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-11 23:04:49 +0200 (Mon, 11 Jul 2016)
Build-Date:2016-07-12 01:31:48
Revision:10526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10526 en) Windows 7 64-Bit
Memory Usage: 371 MB / 910 MB (74 MB allocated, but free)
Java version: 1.8.0_31-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- BuildingGeneralization (1010)
- Create_grid_of_ways (32440)
- FastDraw (32639)
- ImportImagePlugin (32584)
- PicLayer (32495)
- apache-commons (32584)
- buildings_tools (32639)
- ejml (32639)
- fieldpapers (v0.4.0)
- geochat (32561)
- geotools (32584)
- gpsblam (32487)
- imagery_offset_db (32528)
- josm-config (1449603193)
- josm-plugin-opengl (1440156917)
- jts (32539)
- log4j (32309)
- measurement (32454)
- opendata (32584)
- pdfimport (32584)
- poly (32584)
- proj4j (32309)
- rasterfilters (32503)
- todo (29154)
- utilsplugin2 (32584)

Tagging presets:
- D:\Downloads\refugee_crisis_EU.xml
- D:\My Documents\hotosm_tasking_manager_project_1245.xml
- D:\MyRealDocuments\blake-josm-presets-damage.xml
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT-1-preset.xml

Map paint styles:
- D:\MyRealDocuments\<user.name>HOTValidate.zip
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog$ApplyAction@49b70741
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog$CancelAction@f9f1a58
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.help.ContextSensitiveHelpAction@1f0b6b86
- E: java.lang.NullPointerException
- E: java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.plugins.gpsblam.GPSBlamMode@3ca277e6

java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.plugins.gpsblam.GPSBlamMode@3ca277e6
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:379)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:367)
	at org.openstreetmap.josm.plugins.gpsblam.GPSBlamMode.destroy(GPSBlamMode.java:224)
	at org.openstreetmap.josm.gui.IconToggleButton.destroy(IconToggleButton.java:72)
	at org.openstreetmap.josm.gui.MapFrame.destroy(MapFrame.java:341)
	at org.openstreetmap.josm.gui.MainPanel.updateContent(MainPanel.java:58)
	at org.openstreetmap.josm.gui.MainPanel$1.afterLastLayerRemoved(MainPanel.java:162)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:290)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:229)
	at org.openstreetmap.josm.gui.layer.LayerManager$2.run(LayerManager.java:213)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:146)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:210)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:438)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.resetState(MainLayerManager.java:396)
	at org.openstreetmap.josm.Main.shutdown(Main.java:1178)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:117)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:1159)
	at org.openstreetmap.josm.gui.MainFrame$3.windowClosing(MainFrame.java:105)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.Window.processWindowEvent(Unknown Source)
	at javax.swing.JFrame.processWindowEvent(Unknown Source)
	at java.awt.Window.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by Don-vip

Cc: michael2402 added
Component: CorePlugin gpsblam
Description: modified (diff)
Keywords: gsoc-core added
Summary: Error when updating the gpsbalm pluginError when updating the gpsblam plugin

comment:2 Changed 3 years ago by Don-vip

Ticket #13248 has been marked as a duplicate of this ticket.

comment:3 Changed 3 years ago by Don-vip

Priority: normalmajor

comment:4 Changed 3 years ago by michael2402

This will happen if the mode is never used when exiting JOSM:

This is called in enterMode()

MapView.addLayerChangeListener(this);

This is called in destroy() but should be called in exitMode()

MapView.removeLayerChangeListener(this);

comment:5 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o32745:32746].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.