Modify

Opened 5 years ago

Closed 5 years ago

#13219 closed defect (duplicate)

dxfImport no longer works

Reported by: anonymous Owned by: bwallum
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: dxf Cc:

Description

What steps will reproduce the problem?

  1. Ensure plugin dxfImport is installed
  2. Upon start up an error message appears
  3. Keep plugin when offered
  4. Attempts to open a dxf file in a new layer fails


What is the expected result?

no error message at start up
dxf file loads into a new layer with file>open>filename.dxf

What happens instead?

error message at start up and attempts to file>open dxf file fails

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-11 23:04:49 +0200 (Mon, 11 Jul 2016)
Build-Date:2016-07-12 01:31:48
Revision:10526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10526 en_GB) Linux Ubuntu 16.04.1 LTS
Memory Usage: 403 MB / 1753 MB (345 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-0ubuntu4~16.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
- DxfImport
- importvec (32490)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plug-in DxfImport. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.IllegalAccessError: tried to access field org.openstreetmap.josm.actions.ExtensionFileFilter.importers from class org.openstreetmap.josm.plugins.dxfimport.DxfImportPlugin
- W: Disable plug-in - Could not load plug-in DxfImport. Delete from preferences?

Attachments (1)

JOSMdxfImportfail.png (8.0 KB) - added by bwallum 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by bwallum

Attachment: JOSMdxfImportfail.png added

comment:1 Changed 5 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13220.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bwallum.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.