Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13218 closed defect (fixed)

Activating the building plugin results in error

Reported by: hjart Owned by: Don-vip
Priority: critical Milestone:
Component: Plugin buildings_tools Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

Activating the building plugin (pressing B)

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-27 02:48:44 +0200 (Wed, 27 Jul 2016)
Build-Date:2016-07-27 01:36:37
Revision:10659
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10659 da) Linux openSUSE Leap 42.1 (x86_64)
Memory Usage: 759 MB / 1324 MB (492 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-8-jre:pakken openjdk-8-jre er ikke installeret

Dataset consistency test:
[WAY NOT IN REFERRERS] {Node id=-8239 version=0 MV lat=55.32491879513288,lon=9.563730179480384} is part of {Way id=38521953 version=8 MVT nodes=[{Node id=299615535 version=11 V lat=55.3228976,lon=9.562513}, {Node id=3730737492 version=1 V lat=55.3232904,lon=9.5626727}, {Node id=455877576 version=2 MVT lat=55.3234443,lon=9.5627352}, {Node id=455877575 version=2 V lat=55.3238119,lon=9.5628911}, {Node id=455877574 version=2 V lat=55.3241725,lon=9.5630876}, {Node id=1119750463 version=2 V lat=55.3243673,lon=9.5632334}, {Node id=455877572 version=3 MVT lat=55.324641831069926,lon=9.56346464078791}, {Node id=-8239 version=0 MV lat=55.32491879513288,lon=9.563730179480384}, {Node id=1119749296 version=2 V lat=55.3269778,lon=9.5658915}, {Node id=455877564 version=2 V lat=55.3290501,lon=9.5680582}, {Node id=455877563 version=2 V lat=55.3296969,lon=9.5688287}, {Node id=455877562 version=2 V lat=55.3302232,lon=9.5695161}, {Node id=3984731390 version=1 V lat=55.3303833,lon=9.5697561}, {Node id=1119749995 version=2 V lat=55.3308846,lon=9.5705071}, {Node id=455877558 version=2 V lat=55.3317074,lon=9.5717415}, {Node id=455877557 version=2 V lat=55.3321391,lon=9.5723029}, {Node id=455877556 version=2 V lat=55.3329048,lon=9.5732165}, {Node id=455877555 version=2 V lat=55.3348059,lon=9.5754942}, {Node id=455877552 version=4 V lat=55.339191,lon=9.5807117}]} but is not in referrers
[WAY NOT IN REFERRERS] {Node id=-8284 version=0 MV lat=55.32432557084081,lon=9.571100889853307} is part of {Way id=96687850 version=2 MVT nodes=[{Node id=1119749296 version=2 V lat=55.3269778,lon=9.5658915}, {Node id=-8271 version=0 MV lat=55.326669804123355,lon=9.566904573849506}, {Node id=1119750728 version=1 MV lat=55.32653399878584,lon=9.567309587410755}, {Node id=1119750961 version=1 MV lat=55.32580460934918,lon=9.569325267485441}, {Node id=1119750279 version=1 V lat=55.3255721,lon=9.5697551}, {Node id=1119750503 version=1 MV lat=55.32486004534187,lon=9.570667713097404}, {Node id=-8279 version=0 MV lat=55.324681506481475,lon=9.570850103310415}, {Node id=1119750976 version=1 MV lat=55.32445527980457,lon=9.571064680031606}, {Node id=-8284 version=0 MV lat=55.32432557084081,lon=9.571100889853307}, {Node id=1119749271 version=2 V lat=55.322044,lon=9.5708098}]} but is not in referrers


Plugins:
- DirectUpload (32329)
- FastDraw (32639)
- InfoMode (32491)
- Mapillary (32639)
- SimplifyArea (32517)
- apache-commons (32584)
- apache-http (32584)
- buildings_tools (32639)
- ejml (32639)
- geotools (32584)
- jts (32539)
- opendata (32584)
- reverter (32584)
- tagging-preset-tester (32584)
- todo (29154)
- utilsplugin2 (32725)
- wikipedia (32671)

Tagging presets:
- ${HOME}/Dokumenter/HjartsPresets.xml
- http://www.country-linedance.de/daten/Archaeologie-de.zip
- http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1

Last errors/warnings:
- W: Kan ikke slette fil /tmp/Tiles/TMS.data
- W: Kan ikke slette fil /tmp/Tiles/TMS.key
- W: Kan ikke slette fil /tmp/Tiles/TMS.data
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@180eb58e
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@2d6a7a98
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@3691d939
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@56d63684
- W: Kan ikke slette fil /tmp/Tiles/TMS.key
- W: Kan ikke slette fil /tmp/Tiles/TMS.data
- E: java.lang.NoSuchFieldError: isUsablePredicate


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NoSuchFieldError: isUsablePredicate
	at buildings_tools.DrawBuildingAction.updCursor(DrawBuildingAction.java:364)
	at buildings_tools.DrawBuildingAction.mouseMoved(DrawBuildingAction.java:381)
	at java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:330)
	at java.awt.Component.processMouseMotionEvent(Component.java:6580)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3333)
	at java.awt.Component.processEvent(Component.java:6304)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4538)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 3 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o32727:32729].

comment:3 Changed 3 years ago by Don-vip

Component: CorePlugin building_tools

comment:4 Changed 3 years ago by Don-vip

Ticket #13226 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.