Modify

Opened 3 years ago

Closed 3 years ago

#13136 closed defect (fixed)

error waypoint_search plugin

Reported by: pos_ei_don@… Owned by: cinw7
Priority: normal Milestone:
Component: Plugin waypoint_search Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-11 23:04:49 +0200 (Mon, 11 Jul 2016)
Build-Date:2016-07-12 01:31:48
Revision:10526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10526 de) Windows 10 64-Bit
Memory Usage: 213 MB / 989 MB (22 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) Client VM

Plugins:
- BuildingGeneralization (1010)
- ImportImagePlugin (32584)
- ImproveWay (1452443304)
- PicLayer (32495)
- RoadSigns (32584)
- SimplifyArea (32517)
- areaselector (271)
- buildings_tools (32639)
- contourmerge (1014)
- ejml (32639)
- geotools (32584)
- imagery_offset_db (32528)
- imageryadjust (32329)
- indoor_sweepline (32639)
- indoorhelper (32637)
- jts (32539)
- livegps (32470)
- log4j (32309)
- openvisible (32463)
- reltoolbox (32639)
- splinex (32584)
- touchscreenhelper (32550)
- turnrestrictions (32629)
- undelete (32584)
- utilsplugin2 (32584)
- waypoint_search (32551)

Tagging presets:
- %UserProfile%\CloudStation\Tools\josm-climbing.xml
- https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OpenPisteMap&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/SkiingTrail&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/caravan_site&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Mountains&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/TreeCrownDiameter&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/sac_scale&zip=1

Last errors/warnings:
- W: Datei <josm.cache>\tiles\TMS.key kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS.data kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_BLOCK.key kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_BLOCK.data kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX.key kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX.data kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX_v2.key kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX_v2.data kann nicht gelöscht werden
- W: Plugin seems to be adding listener during mapFrameInitialized(): ContourMergeModelManager#wireToJOSM. Layer listeners should be set on plugin load.
- E: java.lang.ArrayIndexOutOfBoundsException: -1

java.lang.ArrayIndexOutOfBoundsException: -1
	at java.util.ArrayList.elementData(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at org.openstreetmap.josm.plugins.waypointSearch.SelectWaypointDialog.mouseClicked(SelectWaypointDialog.java:101)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

LEMnet_D.rar (525.6 KB) - added by anonymous 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by anonymous

Attachment: LEMnet_D.rar added

comment:1 Changed 3 years ago by anonymous

reproducable when loading the attached waypoints-file

comment:2 Changed 3 years ago by Don-vip

Component: CorePlugin waypoint_search
Owner: changed from team to cinw7

comment:3 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o32644:32646].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cinw7.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.