Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13054 closed defect (duplicate)

JOSM invites to upload changeset with no changes

Reported by: dieterdreist Owned by: team
Priority: minor Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. add a tag to a way
  2. remove the tag

What is the expected result?

no modifications done, can close without warning

What happens instead?

JOSM urges to uoload

Please provide any additional information below. Attach a screenshot if possible.

this is the changeset with no modifications that was created (besides a new version of the way):
https://www.openstreetmap.org/changeset/40266105

Maybe this is expected? I should have done "undo" rather than deleting the tag maybe?

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-24 01:49:51 +0200 (Fri, 24 Jun 2016)
Build-Date:2016-06-24 01:34:30
Revision:10473
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10473 en) Mac OS X 10.11.5
Memory Usage: 767 MB / 1820 MB (560 MB allocated, but free)
Java version: 1.8.0_66-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- TombPlugin (46)
- alignways (32161)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- ejml (32158)
- geochat (32158)
- geotools (31895)
- imagery_offset_db (32158)
- jts (31906)
- opendata (32289)
- print (32191)
- proj4j (32158)
- reltoolbox (32158)
- reverter (32158)
- undelete (32158)
- utilsplugin2 (32158)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.history.HistoryBrowserDialog$CloseAction@718c5322
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.help.ContextSensitiveHelpAction@49ebbca9
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.history.HistoryBrowserDialog$ReloadAction@565b6c80
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.history.HistoryBrowserDialog$CloseAction@3c0c2f63
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.help.ContextSensitiveHelpAction@51174121

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #3384.

comment:2 Changed 3 years ago by stoecker

In 10481/josm:

Don't use SideButton outside toggle dialogs, see #12994, see #13054

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.