Modify

Opened 3 years ago

Closed 18 months ago

#13034 closed enhancement (fixed)

Dashed line from "Improve Way Accuracy" stays on map view when "Extrude" is selected

Reported by: osmTOGA Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc: michael2402, kolesar

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Select a way or an area
  2. Press "w" to activate the "Improve Way Accuracy" tool and make sure that the dashed line appears
  3. Press "x" to activate the "Extrude" tool

What is the expected result?

The dashed line disappears.

What happens instead?

The dashed line stays on the map view until either "Extrude" is actually used, another tool gets selected or the map view is changed.

Please provide any additional information below. Attach a screenshot if possible.

I checked in latest and tested and both show the same behaviour.


URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-22 00:48:51 +0200 (Wed, 22 Jun 2016)
Build-Date:2016-06-22 01:34:07
Revision:10453
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10453 de) Windows 7 64-Bit
Memory Usage: 501 MB / 2222 MB (95 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- Mapillary (32158)
- PicLayer (32158)
- RoadSigns (32177)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- continuosDownload (53)
- ejml (32158)
- geochat (32158)
- geotools (31895)
- imagery_offset_db (32158)
- jts (31906)
- measurement (32324)
- opendata (32289)
- reverter (32158)
- todo (29154)
- turnrestrictions (32158)
- utilsplugin2 (32158)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1

Map paint styles:
- %UserProfile%\OSM\JOSM-Paintstyles\Power_lines.mapcss
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1

Last errors/warnings:
- W: Datei <josm.cache>\tiles\TMS_BLOCK.data kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX.key kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX.data kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX_v2.key kann nicht gelöscht werden
- W: Datei <josm.cache>\tiles\TMS_INDEX_v2.data kann nicht gelöscht werden

Attachments (1)

ImproveWay_dashed.png (894.7 KB) - added by osmTOGA 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by osmTOGA

Attachment: ImproveWay_dashed.png added

comment:1 Changed 3 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 3 years ago by michael2402

Cc: michael2402 added

comment:3 Changed 3 years ago by stoecker

Component: CorePlugin improvewayaccuracy
Type: defectenhancement

comment:4 Changed 3 years ago by Klumbumbus

Cc: kolesar added

comment:5 Changed 2 years ago by Klumbumbus

Component: Plugin improvewayaccuracyCore

Thats not from the plugin. It is from the core feature Help/Action/ImproveWayAccuracy

comment:6 Changed 18 months ago by osmTOGA

This problem seems to be fixed in both, latest and tested. Since I haven't been active the last few months, I, unfortunately, can't tell exactly which version corrected this behaviour.

What would now be the procedure? Close the ticket?

comment:7 Changed 18 months ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.