Modify

Opened 3 years ago

Closed 3 years ago

#12951 closed enhancement (fixed)

Clay surfaces

Reported by: Szem Owned by: Szem
Priority: normal Milestone: 16.06
Component: Internal preset Version:
Keywords: clay, surface, i18n Cc:

Description

Hi,
I've found a little mistake of translation of the word CLAY
One value, but different (hungarian) meaning:
item combo "Surface" display value
item "Sports/Sport Facilities/Pitch" combo "Surface" display value
item "Sports/Sport Facilities/Racetrack" combo "Surface" display value
The clay road surface, is different from clay (tennis) court.
Please, separete these values, to be able to translate them correctly
Thanks,
Szem

Attachments (2)

surface.png (5.7 KB) - added by Szem 3 years ago.
Surface Drop Down menu
surface2.png (37.4 KB) - added by Szem 3 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 3 years ago by Klumbumbus

"Sports/Sport Facilities/Racetrack" is not a road. This is the running area around e.g. a soccer pitch (osmwiki:Tag:leisure=track). So the surface value clay should be the same for these running tracks and tennis courts, right?

comment:2 Changed 3 years ago by Szem

item combo "Surface" display value is for road
and is different from
item "Sports/Sport Facilities/Pitch" combo "Surface" display value and
item "Sports/Sport Facilities/Racetrack" combo "Surface" display value are for not road

comment:3 in reply to:  2 Changed 3 years ago by Klumbumbus

Replying to Szem:

item combo "Surface" display value is for road

No the road surface combo does not contain clay.
This is used for riding surface in sport=equestrian and sport=horse_riding

Changed 3 years ago by Szem

Attachment: surface.png added

Surface Drop Down menu

comment:4 Changed 3 years ago by Szem

If item combo "Surface" display value is not for road, what value is for it?
I've attached a screenshot for Surface Drop Down menu, that contains clay.
(and the hungarian translation is "agyag" that is good for that value)

The problem is, if I set "Sports/Sport Facilities/Racetrack" "Surface" value to clay, the hungarian translation will be the same "agyag", that's not correct, the correct translation is "salak"

https://translate.google.hu/#en/hu/clay%20tennis
https://translate.google.hu/#en/hu/clay%20road

comment:5 Changed 3 years ago by stoecker

What you list in the image are all values for surface independent from the other tags. This list stay untranslated always.

JOSM presets don't offer a translation for a surface usage outside Pitch and Racetrack. Especially does it not offer a translation for clay usage in a road, which very likely nobody does.

You're mixing the fact what's possible and what JOSM offers. Sure you can set surface=clay also for a road, but that is not handled in the presets, so you don't need to take care in translation.

comment:6 Changed 3 years ago by Szem

I've found the problem, when the bad translation appears on screen (attached)
But it's OK. I've understood it. I simply don't know what possible or not :)
I think the best I can do, to change the translation from "agyag" to "salak", which is correct for tennis courts, sports tracks etc. Is it OK?

Changed 3 years ago by Szem

Attachment: surface2.png added

comment:7 Changed 3 years ago by stoecker

According to description "salak" is ok, as the agyak will never be shown.

The translation page on launchpad shows you following use cases:

item  combo "Surface" display value
item "Sports/Sport Facilities/Pitch" combo "Surface" display value
item "Sports/Sport Facilities/Racetrack" combo "Surface" display value

I fixed the code a bit, so from now on it will be (change in first line)

chunk riding_surface combo "Surface" display value
item "Sports/Sport Facilities/Pitch" combo "Surface" display value
item "Sports/Sport Facilities/Racetrack" combo "Surface" display value

These are the only uses of clay. According to your description this is always "salak"? If correct, then change it. So JOSM simply does not use the agyak variant ATM.

Is the confusion solved by the update, so that it's clearly meantioning "riding_surface"?

comment:8 Changed 3 years ago by Szem

Thanks! I've changed the translation. This word is used for all surfaces what is in wiki page:
http://wiki.openstreetmap.org/wiki/Key:surface
"surface=clay, Most common on tennis courts. Sometimes used for other sports: soccer, athletic tracks, boules, etc. "
and it's good for riding surface too.

comment:9 in reply to:  7 Changed 3 years ago by Klumbumbus

Replying to stoecker:

I fixed the code a bit

Nice, this makes it more clear.

comment:10 Changed 3 years ago by Klumbumbus

Keywords: i18n added
Milestone: 16.06
Resolution: fixed
Status: newclosed

If your are interested in the code Szem: The JOSM preset file is here: https://josm.openstreetmap.de/browser/josm/trunk/data/defaultpresets.xml

  • In line 16 there are the surface values which are later used in the different road presets. (no clay here)
  • In line 33 there are the surface values which are later used in the riding presets (sport=equestrian and sport=horse_riding)
  • In line 5496 there are the surface values which are used in the leisure=pitch preset
  • In line 5511 there are the surface values which are used in the leisure=track preset

(However if someone else or you already (manually) tagged a road with surface=clay and then you open its road preset, clay will appear there in the list.)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Szem.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.