Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12894 closed defect (fixed)

JOSM does not start with Java 9b116

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 16.06
Component: Core Version: tested
Keywords: java9 javabug Cc:

Description

Previously, everything was ok . Maybe I 'm doing something wrong... I'm not an expert.

rafal@rafalr ~ $ java -jar /home/rafal/Programy/josm-tested.jar
BŁĄD: java.util.MissingResourceException: Can't find bundle for base name sun.awt.resources.awt, locale pl_PL. Przyczyna: java.lang.IllegalAccessException: unnamed modules can't load sun.awt.resources.awt in named module java.desktop
java.util.MissingResourceException: Can't find bundle for base name sun.awt.resources.awt, locale pl_PL
	at java.util.ResourceBundle.throwMissingResourceException(java.base@9-ea/ResourceBundle.java:2004)
	at java.util.ResourceBundle.getBundleImpl(java.base@9-ea/ResourceBundle.java:1685)
	at java.util.ResourceBundle.getBundleImpl(java.base@9-ea/ResourceBundle.java:1591)
	at java.util.ResourceBundle.getBundleImpl(java.base@9-ea/ResourceBundle.java:1560)
	at java.util.ResourceBundle.getBundle(java.base@9-ea/ResourceBundle.java:912)
	at org.openstreetmap.josm.data.Preferences.updateSystemProperties(Preferences.java:1325)
	at org.openstreetmap.josm.data.Preferences.load(Preferences.java:578)
	at org.openstreetmap.josm.data.Preferences.init(Preferences.java:679)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:369)
Caused by: java.lang.IllegalAccessException: unnamed modules can't load sun.awt.resources.awt in named module java.desktop
	at java.util.ResourceBundle$Control.newBundle(java.base@9-ea/ResourceBundle.java:3128)
	at java.util.ResourceBundle.loadBundle(java.base@9-ea/ResourceBundle.java:1943)
	at java.util.ResourceBundle.findBundle(java.base@9-ea/ResourceBundle.java:1767)
	at java.util.ResourceBundle.findBundle(java.base@9-ea/ResourceBundle.java:1718)
	at java.util.ResourceBundle.findBundle(java.base@9-ea/ResourceBundle.java:1718)
	at java.util.ResourceBundle.getBundleImpl(java.base@9-ea/ResourceBundle.java:1659)
	... 7 more

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by Don-vip

Keywords: java9 added
Owner: changed from team to anonymous
Status: newneedinfo

Java 9 is not officialy supported yet. What build are you using?

comment:2 Changed 5 years ago by anonymous

java version "9-ea"
Java(TM) SE Runtime Environment (build 9-ea+116)
Java HotSpot(TM) 64-Bit Server VM (build 9-ea+116, mixed mode)

I dont have any prblem with JOSM (10168).

comment:3 Changed 5 years ago by Don-vip

Summary: JOSM does not startJOSM does not start with Java 9b116

Can you please try the following:

  • with latest build (b120)
  • with English language (java -jar josm-tested.jar --language=en)

Thanks.

comment:4 Changed 5 years ago by Don-vip

Keywords: javabug added

comment:5 Changed 5 years ago by Don-vip

Milestone: 16.06

comment:6 Changed 5 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 10322/josm:

fix #12894 - JOSM does not start with Java 9b116+

comment:7 Changed 5 years ago by Don-vip

Thanks for the bug report. Please note that Java 9 is not finished yet. If you want the best JOSM user experience with it you need to launch it as follows:

java -addmods java.xml.bind -XaddExports:java.base/sun.security.util=ALL-UNNAMED -XaddExports:java.base/sun.security.x509=ALL-UNNAMED -XaddExports:java.xml.bind/javax.xml.bind=ALL-UNNAMED -jar josm-latest.jar

See #11924 for details.

Last edited 5 years ago by Don-vip (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.